aboutsummaryrefslogtreecommitdiff
path: root/src/hydrilla.egg-info
diff options
context:
space:
mode:
Diffstat (limited to 'src/hydrilla.egg-info')
-rw-r--r--src/hydrilla.egg-info/PKG-INFO28
-rw-r--r--src/hydrilla.egg-info/SOURCES.txt2
-rw-r--r--src/hydrilla.egg-info/requires.txt5
3 files changed, 22 insertions, 13 deletions
diff --git a/src/hydrilla.egg-info/PKG-INFO b/src/hydrilla.egg-info/PKG-INFO
index dc23bac..b7cad65 100644
--- a/src/hydrilla.egg-info/PKG-INFO
+++ b/src/hydrilla.egg-info/PKG-INFO
@@ -1,6 +1,6 @@
Metadata-Version: 2.1
Name: hydrilla
-Version: 1.0
+Version: 1.1b1
Summary: Hydrilla repository server
Home-page: https://git.koszko.org/pydrilla
Author: Wojtek Kosior
@@ -19,21 +19,21 @@ Description: # Hydrilla (Python implementation)
* Python3 (>= 3.7)
* [hydrilla.builder](https://git.koszko.org/hydrilla-builder/)
- * flask
+ * flask (>= 1.1)
* click
* jsonschema (>= 3.0)
### Build
+ * build (a PEP517 package builder)
* setuptools
* wheel
* setuptools_scm
- * babel
+ * babel (Python library)
### Test
* pytest
- * reuse
## Building
@@ -55,15 +55,11 @@ Description: # Hydrilla (Python implementation)
To perform the build and installation without PyPI, first install all dependencies system-wide. For example, in Debian-based distributions (including Trisquel):
``` shell
sudo apt install python3-flask python3-flask python3-jsonschema \
- python3-setuptools python3-setuptools-scm python3-babel python3-wheel
+ python3-setuptools python3-setuptools-scm python3-babel python3-wheel \
+ python3-build
```
- Then, block programs you're about to spawn from accessing https://pypi.org. If running on a GNU/Linux system you can utilize Linux user namespaces:
- ``` shell
- unshare -Urn
- ```
-
- The above will put you in a network-isolated shell. If you're using a virtualenv, activate it **after** the `unshare` command.
+ If you're using `virtualenv` command to create a virtual environment, make sure you invoke it with `--system-site-packages` and `--no-download`. The first option is necessary for packages installed inside the virtualenv to be able to use globally-installed dependencies. The second one will make `virtualenv` use locally-available base libraries (setuptools, etc.) instead of downloading them from PyPI.
Now, in unpacked source directories of **both** `hydrilla-builder` and `hydrilla`, run the build and installation commands:
``` shell
@@ -81,6 +77,16 @@ Description: # Hydrilla (Python implementation)
python3 -m pytest
```
+ ## Installation from wheels
+
+ Instead of building yourself you can use Python wheels provided on [Hydrilla downloads page](https://hydrillabugs.koszko.org/projects/hydrilla/wiki/Releases).
+
+ ``` shell
+ python3 -m pip install \
+ path/to/downloaded/hydrilla.builder-1.1b1-py3-none-any.whl \
+ path/to/downloaded/hydrilla-1.1b1-py3-none-any.whl
+ ```
+
## Running
### Hydrilla command
diff --git a/src/hydrilla.egg-info/SOURCES.txt b/src/hydrilla.egg-info/SOURCES.txt
index 461f1fc..d30f96a 100644
--- a/src/hydrilla.egg-info/SOURCES.txt
+++ b/src/hydrilla.egg-info/SOURCES.txt
@@ -3,6 +3,7 @@ MANIFEST.in
README.md
README.md.license
babel.cfg
+conftest.py
pyproject.toml
pytest.ini
setup.cfg
@@ -35,6 +36,7 @@ src/hydrilla/server/templates/base.html
src/hydrilla/server/templates/index.html
tests/__init__.py
tests/config.json
+tests/helpers.py
tests/test_server.py
tests/source-package-example/README.txt
tests/source-package-example/README.txt.license
diff --git a/src/hydrilla.egg-info/requires.txt b/src/hydrilla.egg-info/requires.txt
index 026f10d..62e05e0 100644
--- a/src/hydrilla.egg-info/requires.txt
+++ b/src/hydrilla.egg-info/requires.txt
@@ -1,8 +1,9 @@
-flask
-hydrilla.builder==1.0
+flask>=1.1
+hydrilla.builder==1.1b1
jsonschema>=3.0
[setup]
+babel
setuptools_scm
[test]