aboutsummaryrefslogtreecommitdiff
path: root/setup.py
diff options
context:
space:
mode:
authorWojtek Kosior <koszko@koszko.org>2021-11-13 20:33:57 +0100
committerWojtek Kosior <koszko@koszko.org>2021-11-13 20:33:57 +0100
commita14ab0a7601ff5c197fe43d42410d8ed6bfd26a8 (patch)
treebefa6fc0b1de552bae1e2a832a25cb0dd8f58412 /setup.py
downloadhaketilo-hydrilla-a14ab0a7601ff5c197fe43d42410d8ed6bfd26a8.tar.gz
haketilo-hydrilla-a14ab0a7601ff5c197fe43d42410d8ed6bfd26a8.zip
initial commit
Diffstat (limited to 'setup.py')
-rwxr-xr-xsetup.py76
1 files changed, 76 insertions, 0 deletions
diff --git a/setup.py b/setup.py
new file mode 100755
index 0000000..4f87ecc
--- /dev/null
+++ b/setup.py
@@ -0,0 +1,76 @@
+#!/usr/bin/env python3
+
+# SPDX-License-Identifier: CC0-1.0
+
+# Setup script
+#
+# This file is part of Hydrilla
+#
+# Copyright (C) 2021 Wojtek Kosior
+#
+# This file is free software: you can redistribute it with or without
+# modification under the terms of the CC0 1.0 Universal License as
+# published by the Creative Commons Corporation.
+#
+# This file is distributed in the hope that it will be useful,
+# but WITHOUT ANY WARRANTY; without even the implied warranty of
+# MERCHANTABILITY or FITNESS FOR A PARTICULAR PURPOSE. See the
+# CC0 1.0 Universal License for more details.
+
+from setuptools import setup, find_packages
+import sys
+import pathlib
+
+settings = {}
+settings['version'] = '0.2'
+settings['app_package_name'] = 'pydrilla'
+settings['project_root'] = pathlib.Path(__file__).resolve().parent
+packages_root = settings['project_root'] / 'src'
+main_package_dir = packages_root / settings['app_package_name']
+settings['locales_dir'] = main_package_dir / 'locales'
+settings['config_path'] = main_package_dir / 'development_config.json'
+
+sys.path.insert(0, str(packages_root))
+import test
+import pydrilla_dev_helper
+
+helper = pydrilla_dev_helper.Helper(**settings)
+
+setup(
+ name=settings['app_package_name'],
+ version=settings['version'],
+ description='Hydrilla repository server (Python implementation)',
+# long_description='...',
+# long_description_content_type='text/plain',
+ url='https://hydrillabugs.koszko.org',
+ author='Wojtek Kosior',
+ author_email='koszko@koszko.org',
+ classifiers=[
+ 'Development Status :: 3 - Alpha',
+ 'Intended Audience :: Developers',
+ 'Environment :: Web Environment',
+ 'Framework :: Flask',
+ 'Topic :: Internet :: WWW/HTTP :: WSGI',
+ 'License :: OSI Approved :: GNU Affero General Public License v3 or later (AGPLv3+)',
+ 'Natural Language :: English',
+ 'Programming Language :: Python :: 3 :: Only'
+ ],
+ package_dir={'': 'src'},
+ packages=find_packages(where='src'),
+ zip_safe=False,
+ install_requires=['flask'],
+ extras_require={
+ 'test': ['pytest'],
+ },
+ package_data={
+ 'pydrilla': ['config.json', *helper.locale_files_relative()],
+ 'test': []
+ },
+ cmdclass=helper.commands()
+ # project_urls={
+ # 'Bug Reports': 'https://',
+ # 'Funding': 'https://',
+ # 'Say Thanks!': 'http://',
+ # 'Source': 'https://',
+ # },
+)