aboutsummaryrefslogtreecommitdiff
blob: 5cd6021cce48f5abfc75238feb13b3b28a681d33 (plain)
blob size (859KB) exceeds display size limit (100KB).
' href='#n15'>15 16 17 18 19 20 21 22 23 24 25 26 27 28 29 30 31 32 33 34 35 36 37 38 39 40 41 42 43 44 45 46 47 48 49 50 51 52 53 54 55 56 57 58 59 60 61 62 63 64 65 66 67 68 69 70 71 72 73 74 75 76 77 78 79 80 81 82 83
;;; GNU Guix --- Functional package management for GNU
;;; Copyright © 2012 Nikita Karetnikov <nikita@karetnikov.org>
;;; Copyright © 2012, 2013 Ludovic Courtès <ludo@gnu.org>
;;;
;;; This file is part of GNU Guix.
;;;
;;; GNU Guix is free software; you can redistribute it and/or modify it
;;; under the terms of the GNU General Public License as published by
;;; the Free Software Foundation; either version 3 of the License, or (at
;;; your option) any later version.
;;;
;;; GNU Guix is distributed in the hope that it will be useful, but
;;; WITHOUT ANY WARRANTY; without even the implied warranty of
;;; MERCHANTABILITY or FITNESS FOR A PARTICULAR PURPOSE.  See the
;;; GNU General Public License for more details.
;;;
;;; You should have received a copy of the GNU General Public License
;;; along with GNU Guix.  If not, see <http://www.gnu.org/licenses/>.

(define-module (gnu packages attr)
  #:use-module (guix licenses)
  #:use-module (gnu packages perl)
  #:use-module (gnu packages gettext)
  #:use-module (guix packages)
  #:use-module (guix download)
  #:use-module (guix build-system gnu))

(define-public attr
  (package
    (name "attr")
    (version "2.4.46")
    (source
     (origin
      (method url-fetch)
      (uri (string-append "mirror://savannah/attr/attr-"
                          version ".src.tar.gz"))
      (sha256
       (base32
        "07qf6kb2zk512az481bbnsk9jycn477xpva1a726n5pzlzf9pmnw"))))
    (build-system gnu-build-system)
    (arguments
     `(#:phases
       (alist-cons-after
        'configure 'patch-makefile-SHELL
        (lambda _
          (patch-makefile-SHELL "include/buildmacros"))
        (alist-replace
         'install
         (lambda _
           (zero? (system* "make"
                           "install"
                           "install-lib"
                           "install-dev")))

         ;; When building natively, adjust the test cases.
         ,(if (%current-target-system)
              '%standard-phases
              '(alist-replace 'check
                              (lambda _
                                ;; Use the right shell.
                                (substitute* "test/run"
                                  (("/bin/sh")
                                   (which "bash")))

                                (system* "make" "tests" "-C" "test")

                                ;; XXX: Ignore the test result since this is
                                ;; dependent on the underlying file system.
                                #t)
                              %standard-phases))))))
    (inputs
     ;; Perl is needed to run tests; remove it from cross builds.
     (if (%current-target-system)
         '()
         `(("perl" ,perl))))
    (native-inputs
     `(("gettext" ,gnu-gettext)))

    (home-page "http://savannah.nongnu.org/projects/attr/")
    (synopsis "Library and tools for manipulating extended attributes")
    (description
     "Portable library and tools for manipulating extended attributes.")
    (license (list gpl2+ lgpl2.1+))))
ompilation.Tobias Geerinckx-Rice 2022-01-08gnu: man-db: Use G-expressions.Tobias Geerinckx-Rice 2021-12-13gnu: Simplify package inputs.Ludovic Courtès 2021-11-21gnu: help2man: Resurrect cross-building.Jan (janneke) Nieuwenhuizen 2021-10-12Merge remote-tracking branch 'origin/master' into core-updates-frozen.Mathieu Othacehe 2021-10-04gnu: xmltoman: Fix build.Guillaume Le Vaillant 2021-09-24gnu: mandoc: Update to 1.14.6.Tobias Geerinckx-Rice 2021-09-17Merge branch 'master' into core-updates-frozenMarius Bakke 2021-09-07gnu: mandoc: Add $MANPATH to native-search-paths.Milkey Mouse 2021-09-07Merge branch 'master' into core-updates-frozenLudovic Courtès 2021-08-27gnu: man-pages: Update to 5.13.Tobias Geerinckx-Rice 2021-07-18Merge branch 'master' into core-updatesLudovic Courtès