Share /gnu/store in the BubbleWrap container and remove FHS mounts. This is a Guix-specific patch not meant to be upstreamed. diff --git a/Source/WebKit/UIProcess/Launcher/glib/BubblewrapLauncher.cpp b/Source/WebKit/UIProcess/Launcher/glib/BubblewrapLauncher.cpp index f0a5e4b05dff..88b11f806968 100644 --- a/Source/WebKit/UIProcess/Launcher/glib/BubblewrapLauncher.cpp +++ b/Source/WebKit/UIProcess/Launcher/glib/BubblewrapLauncher.cpp @@ -854,27 +854,12 @@ GRefPtr bubblewrapSpawn(GSubprocessLauncher* launcher, const Proces "--ro-bind", "/sys/dev", "/sys/dev", "--ro-bind", "/sys/devices", "/sys/devices", - "--ro-bind-try", "/usr/share", "/usr/share", - "--ro-bind-try", "/usr/local/share", "/usr/local/share", "--ro-bind-try", DATADIR, DATADIR, - - // We only grant access to the libdirs webkit is built with and - // guess system libdirs. This will always have some edge cases. - "--ro-bind-try", "/lib", "/lib", - "--ro-bind-try", "/usr/lib", "/usr/lib", - "--ro-bind-try", "/usr/local/lib", "/usr/local/lib", "--ro-bind-try", LIBDIR, LIBDIR, -#if CPU(ADDRESS64) - "--ro-bind-try", "/lib64", "/lib64", - "--ro-bind-try", "/usr/lib64", "/usr/lib64", - "--ro-bind-try", "/usr/local/lib64", "/usr/local/lib64", -#else - "--ro-bind-try", "/lib32", "/lib32", - "--ro-bind-try", "/usr/lib32", "/usr/lib32", - "--ro-bind-try", "/usr/local/lib32", "/usr/local/lib32", -#endif - "--ro-bind-try", PKGLIBEXECDIR, PKGLIBEXECDIR, + + // Bind mount the store inside the WebKitGTK sandbox. + "--ro-bind", "@storedir@", "@storedir@", }; if (launchOptions.processType == ProcessLauncher::ProcessType::DBusProxy) { ommitter
path: root/gnu/packages/elm.scm
12-18 ove unused function findOutput....
AgeCommit message (Expand)Author
daemon: Make "opening file" error messages distinguishable....Ludovic Courtès
2023-05-062023-07-06installer: Restore LatGrkCyr-8x16 console font depending on language....Denys Nykula
2022-11-20installer: Add comment above the 'packages' field....Ludovic Courtès
Maxime Devos
2022-09-11daemon: Remove unused function exportPaths....Maxime Devos
2022-09-11daemon: Remove unused function openStore....Maxime Devos
2022-06-05daemon: Quote consistently within a string....Tobias Geerinckx-Rice
2022-05-29daemon: Clarify ‘--check’ error when outputs are missing....Tobias Geerinckx-Rice
2022-05-18daemon: runChild() is forbidden to talk during environment set up...yarl-baudig@mailoo.org
2022-04-14daemon: Support systemd-style socket activation....Ludovic Courtès
2022-01-18daemon: Always default to gzip for log compression....Ludovic Courtès
2021-11-27daemon: Print the line whence we expect an integer....Tobias Geerinckx-Rice
2021-11-25daemon: Read substitute nar size as 'unsigned long long'....Ludovic Courtès
2021-11-25daemon: Read unsigned nar size and download size from substituter....Ludovic Courtès
2021-11-19daemon: Micro-optimize 'deletePath'....Ludovic Courtès
2021-11-16daemon: Do not deduplicate files smaller than 8 KiB....Ludovic Courtès
2021-10-01build: Don’t delete ‘guix-gc.timer’ file....Xinglu Chen
2021-09-20etc: Add systemd files for running ‘guix gc’ periodically...Thiago Jung Bauermann