Description: Fix for libpng 1.6 Author: Programmer Nerd Origin: https://bugs.debian.org/cgi-bin/bugreport.cgi?bug=743388#20 Bug-Debian: https://bugs.debian.org/cgi-bin/bugreport.cgi?bug=743388 Reviewed-by: Tobias Frost > Last-Update: 2016-04-07 --- This patch header follows DEP-3: http://dep.debian.net/deps/dep3/ --- a/src/t4k_loaders.c +++ b/src/t4k_loaders.c @@ -1028,12 +1028,9 @@ { png_init_io(png_ptr, fi); - info_ptr->width = surf->w; - info_ptr->height = surf->h; - info_ptr->bit_depth = 8; - info_ptr->color_type = PNG_COLOR_TYPE_RGB_ALPHA; - info_ptr->interlace_type = 1; - info_ptr->valid = 0; /* will be updated by various png_set_FOO() functions */ + png_set_IHDR(png_ptr, info_ptr, surf->w, surf->h, 8, + PNG_COLOR_TYPE_RGB_ALPHA, PNG_INTERLACE_NONE, + PNG_COMPRESSION_TYPE_DEFAULT, PNG_FILTER_TYPE_DEFAULT); png_set_sRGB_gAMA_and_cHRM(png_ptr, info_ptr, PNG_sRGB_INTENT_PERCEPTUAL); ef='/guix/refs/?id=3528d888eed2e226826085f68b40171dee18c5cb'>refslogtreecommitdiff
path: root/nix
AgeCommit message (Expand)Author
2024-05-13daemon: Loop over ‘copy_file_range’ upon short writes....Ludovic Courtès
2024-03-12daemon: Address shortcoming in previous security fix for CVE-2024-27297....Ludovic Courtès
2024-03-11daemon: Protect against FD escape when building fixed-output derivations (CVE......Ludovic Courtès
2024-01-05daemon: Change default ‘timeout’ and ‘max-silent-time’ values....Ludovic Courtès
2023-12-17daemon: Fix my own whitespace errors....Tobias Geerinckx-Rice
2023-12-10daemon: Sacrifice builders on OOM....Tobias Geerinckx-Rice
2023-12-11daemon: Implement ‘substitute-urls’ RPC....Ludovic Courtès
2023-12-04daemon: Simplify “empty status” substitute error message....Ludovic Courtès
2023-09-24Revert "build: Add missing guix-gc.timer file to binary tarball."...Tobias Geerinckx-Rice
2023-09-26daemon: Add “git-download” built-in builder....Ludovic Courtès
2023-09-09daemon: Fix build with GCC 13....Sören Tempel
2023-08-31build: Add missing guix-gc.timer file to binary tarball....Maxim Cournoyer
2023-01-09daemon: Improve error message for wrong hash sizes....Ludovic Courtès
2022-12-18daemon: Make "opening file" error messages distinguishable....Ludovic Courtès
2022-10-17Revert "nix: Guard against removing temporary roots of living processes."...Ludovic Courtès
2022-10-07nix: Guard against removing temporary roots of living processes....Ludovic Courtès
2022-09-11daemon: Remove unused function findOutput....Maxime Devos
2022-09-11daemon: Remove unused function exportPaths....Maxime Devos
2022-09-11daemon: Remove unused function openStore....Maxime Devos