We need one patch on top of 0.3.8 for compatibility with Werkzeug 1.0.
Taken from upstream:
https://github.com/flask-restful/flask-restful/commit/73376a488907af3042b52678ac4c23f8a8911e5b
diff --git a/tests/test_api.py b/tests/test_api.py
index f7f8e661..6795d362 100644
--- a/tests/test_api.py
+++ b/tests/test_api.py
@@ -445,7 +445,9 @@ def test_handle_non_api_error(self):
resp = app.get("/foo")
self.assertEquals(resp.status_code, 404)
- self.assertEquals('text/html', resp.headers['Content-Type'])
+ # in newer versions of werkzeug this is `text/html; charset=utf8`
+ content_type, _, _ = resp.headers['Content-Type'].partition(';')
+ self.assertEquals('text/html', content_type)
def test_non_api_error_404_catchall(self):
app = Flask(__name__)
diff --git a/tests/test_reqparse.py b/tests/test_reqparse.py
index 2f1fbedf..9776f17c 100644
--- a/tests/test_reqparse.py
+++ b/tests/test_reqparse.py
@@ -2,9 +2,9 @@
import unittest
from mock import Mock, patch
from flask import Flask
-from werkzeug import exceptions, MultiDict
+from werkzeug import exceptions
from werkzeug.wrappers import Request
-from werkzeug.datastructures import FileStorage
+from werkzeug.datastructures import FileStorage, MultiDict
from flask_restful.reqparse import Argument, RequestParser, Namespace
import six
import decimal
34'>commitdiff
|
Age | Commit message (Expand) | Author |
2024-12-13 | gnu: Add python-setuptools/python-wheel where necessary....Changes to pyproject-build-system require explicit dependency on
setuptools/wheel.
Change-Id: Icd7699fc1dc56e974ae7568f2ae916dbf876bea5
| Lars-Dominik Braun |
2024-12-13 | build-system/pyproject: Use python-sans-pip-wrapper as default-python....Also adds python-setuptools and python-wheel to relevant packages,
either to native-inputs or to propagated inputs if the pkg_resources
Python module is loaded at runtime.
* guix/build-system/pyproject.scm (default-python): Default to
python-sans-pip-wrapper.
Change-Id: I2d986c2225114f54459dd6bb360913106e52cdf4
| Lars-Dominik Braun |
2024-09-25 | gnu: mscgen: Fix dependencies....* gnu/packages/graph.scm (mscgen)
[inputs]: Add fontconfig, freetype, libjpeg-turbo, libpng, zlib.
Change-Id: If185bcb2f786f6493c20040b47e93440987d7243
Signed-off-by: Ludovic Courtès <ludo@gnu.org>
| Sébastien Lerique |
2024-08-31 | gnu: python-graph-tool: Import the correct set of modules....* gnu/packages/graph.scm (python-graph-tool) [arguments]
<modules>: Replace %default-gnu-imported-modules with %default-gnu-modules.
Change-Id: I9d0d70a386e1131250feb16ab23089c66f6dec8e
| Maxim Cournoyer |
2024-08-31 | build-systems: gnu: Export %default-gnu-imported-modules and %default-gnu-mod......Until now users would have to cargo cult or inspect the private
%default-modules variable of (guix build-systems gnu) to discover which
modules to include when extending the used modules via the #:modules argument.
The renaming was automated via the command:
$ git grep -l %gnu-build-system-modules
| xargs sed 's/%gnu-build-system-modules/%default-gnu-imported-modules/' -i
* guix/build-system/gnu.scm (%gnu-build-system-modules): Rename to...
(%default-gnu-imported-modules): ... this.
(%default-modules): Rename to...
(%default-gnu-modules): ... this. Export.
(dist-package, gnu-build, gnu-cross-build): Adjust accordingly.
Change-Id: Idef307fff13cb76f3182d782b26e1cd3a5c757ee
| Maxim Cournoyer |
2024-05-05 | gnu: python-graphtools: Fix tests....* gnu/packages/graph.scm (python-graphtools)[arguments]: Add 'patch-tests
phase.
Change-Id: I5ffb4321ddd7e33e812bcb1cf67cee069b07b5f8
| Ricardo Wurmus |
2024-05-05 | gnu: python-pygsp: Add missing input....* gnu/packages/graph.scm (python-pygsp)[native-inputs]: Add python-pytest.
Change-Id: I94cd4e160dcbecfbb491c0d101bcbeb761189876
| Ricardo Wurmus |
2024-04-04 | gnu: igraph: Switch to openblas....* gnu/packages/graph.scm (igraph): Switch input dependency from
lapack to openblas.
Change-Id: Idcaada16496d2854cce7375b4d9fa647430206eb
Signed-off-by: Ludovic Courtès <ludo@gnu.org>
| Romain GARBAGE |
2024-03-31 | gnu: python-plotly: Update to 5.20.0....* gnu/packages/graph.scm (python-plotly): Update to 5.20.0.
Change-Id: I0df931646677dbceb1fea7912781bc74e0207dcb
| Vinicius Monego |