aboutsummaryrefslogtreecommitdiff
path: root/gnu/packages/graph.scm
diff options
context:
space:
mode:
authorLars-Dominik Braun <lars@6xq.net>2024-02-22 20:47:54 +0100
committerSharlatan Hellseher <sharlatanus@gmail.com>2024-12-13 20:18:25 +0000
commit6d97c15911a51d29f91e3656f9c4ab38e08d7f21 (patch)
treea42bcc8f38f2532ca0218d92323c993729912961 /gnu/packages/graph.scm
parent1ef178c644178304b24bd29c7563ab0529c15f8f (diff)
downloadguix-6d97c15911a51d29f91e3656f9c4ab38e08d7f21.tar.gz
guix-6d97c15911a51d29f91e3656f9c4ab38e08d7f21.zip
gnu: Add python-setuptools/python-wheel where necessary.
Changes to pyproject-build-system require explicit dependency on setuptools/wheel. Change-Id: Icd7699fc1dc56e974ae7568f2ae916dbf876bea5
Diffstat (limited to 'gnu/packages/graph.scm')
-rw-r--r--gnu/packages/graph.scm2
1 files changed, 2 insertions, 0 deletions
diff --git a/gnu/packages/graph.scm b/gnu/packages/graph.scm
index 46e556ecc0..c8bd25af9c 100644
--- a/gnu/packages/graph.scm
+++ b/gnu/packages/graph.scm
@@ -526,7 +526,9 @@ graphs in Python.")
(inputs (list igraph))
(native-inputs
(list python-ddt
+ python-setuptools
python-setuptools-scm
+ python-wheel
pkg-config))
(home-page "https://github.com/vtraag/louvain-igraph")
(synopsis "Implementation of the Louvain algorithm")