Ensure memory accesses in the sha3 module are aligned on ARM as it causes problems when running 32-bit code on a 64-bit kernel. Patch taken from upstream bug report: https://bugs.python.org/issue36515 --- a/Modules/_sha3/sha3module.c +++ b/Modules/_sha3/sha3module.c @@ -64,6 +64,12 @@ #define PLATFORM_BYTE_ORDER IS_BIG_ENDIAN #endif +/* Bus error on 32-bit ARM due to un-aligned memory accesses; 64-bit ARM + * doesn't complain but un-aligned memory accesses are sub-optimal */ +#if defined(__arm__) || defined(__aarch64__) +#define NO_MISALIGNED_ACCESSES +#endif + /* mangle names */ #define KeccakF1600_FastLoop_Absorb _PySHA3_KeccakF1600_FastLoop_Absorb #define Keccak_HashFinal _PySHA3_Keccak_HashFinal bmit();'> Wojtek's customized Guix
aboutsummaryrefslogtreecommitdiff
path: root/gnu/packages/graph.scm
AgeCommit message (Expand)Author
2020-07-16gnu: Use HTTPS for igraph.org....Tobias Geerinckx-Rice
2020-07-12gnu: Remove ".git" from "https://github/…/….git"....Ludovic Courtès
2020-06-22gnu: python-plotly: Update to 4.8.1....Pierre Langlois
2020-06-13gnu: r-rgraphviz: Update to 2.32.0....Ricardo Wurmus
2020-03-30Merge branch 'master' into core-updates...Marius Bakke
2020-03-29gnu: igraph: Update to 0.8.1....Tobias Geerinckx-Rice
2020-03-27gnu: mscgen: Fix build with gd >= 2.3.0....Marius Bakke
2020-03-24gnu: r-igraph: Update to 1.2.5....Ricardo Wurmus
2020-03-04gnu: Update pypi.python.org home pages & use HTTPS....Tobias Geerinckx-Rice
2020-02-24gnu: python-igraph: Update to 0.8.0....Ricardo Wurmus
2020-02-24gnu: igraph: Update to 0.8.0....Ricardo Wurmus
2020-02-11gnu: Add mscgen....Alexander Krotov
2020-01-21gnu: Use HTTPS for bioconductor.org....Tobias Geerinckx-Rice