Build against the system's HIDAPI instead of the bundled one.
--- open-zwave-1.6-checkout/cpp/build/support.mk 2019-06-16 15:15:34.258331628 +0200
+++ open-zwave-1.6-checkout/cpp/build/support.mk 2019-06-16 15:15:54.698249462 +0200
@@ -86,6 +86,10 @@ endif
endif
SED := sed
+# Build against the system's HIDAPI.
+CPPFLAGS += $(shell pkg-config hidapi-libusb --cflags)
+LDFLAGS += $(shell pkg-config hidapi-libusb --libs)
+
#determine if we are release or debug Build and set appropriate flags
ifeq ($(BUILD), release)
CFLAGS += -c $(RELEASE_CFLAGS)
>
|
Wojtek's customized Guix | |
Age | Commit message (Expand) | Author |
2024-09-30 | gnu: Update python-rdflib to 7.0.0....* gnu/packages/rdf.scm: Add updated recipe for python-rdflib; Keep
python-rdflib-6 for compatibility.
* gnu/packages/python-xyz.scm: Build python-prov with python-rdflib-6 because
rdflib-7 is not supported.
* gnu/packages/bioinformatics.scm: Build cwltool with python-rdflib-6 because
it fails to build with rdflib-7.
Change-Id: Ibc40c16ede20e69e702915488d6b2f0a7e70b868
| Roel Janssen |
2024-08-31 | gnu: lrdf: Add missing input....* gnu/packages/rdf.scm (lrdf)[inputs]: Add mit-krb5, nettle. Remove
input labels.
Change-Id: I167e117b82f5a4cd260b7f02c547441b4c984369
| Efraim Flashner |
2024-03-10 | gnu: Remove python-rdflib-jsonld....* gnu/packages/rdf.scm (python-rdflib-jsonld): Delete variable.
Change-Id: I4756396d70eb64ae01b4f6f6c416d9a34a124942
| Arun Isaac |
2024-03-10 | gnu: Remove python-rdflib-5....* gnu/packages/rdf.scm (python-rdflib-5): Delete variable.
Change-Id: I3a2dfe42805ccc5eedc5b71d900dfae2aa91d7a1
| Arun Isaac |