aboutsummaryrefslogtreecommitdiff
path: root/gnu/packages/rdf.scm
diff options
context:
space:
mode:
authorRoel Janssen <roel@gnu.org>2024-09-10 21:19:50 +0200
committerRoel Janssen <r.r.e.janssen@tudelft.nl>2024-09-30 22:48:09 +0200
commitd057d59170446fe47ddedd7eb281ca2a1dfc05e9 (patch)
tree639e97e2289c70b91d9c4c2c8093793b1d95f9ff /gnu/packages/rdf.scm
parent2bd04883ed644fb2b8a3c33d03574cdd810043f4 (diff)
downloadguix-d057d59170446fe47ddedd7eb281ca2a1dfc05e9.tar.gz
guix-d057d59170446fe47ddedd7eb281ca2a1dfc05e9.zip
gnu: Update python-rdflib to 7.0.0.
* gnu/packages/rdf.scm: Add updated recipe for python-rdflib; Keep python-rdflib-6 for compatibility. * gnu/packages/python-xyz.scm: Build python-prov with python-rdflib-6 because rdflib-7 is not supported. * gnu/packages/bioinformatics.scm: Build cwltool with python-rdflib-6 because it fails to build with rdflib-7. Change-Id: Ibc40c16ede20e69e702915488d6b2f0a7e70b868
Diffstat (limited to 'gnu/packages/rdf.scm')
-rw-r--r--gnu/packages/rdf.scm43
1 files changed, 43 insertions, 0 deletions
diff --git a/gnu/packages/rdf.scm b/gnu/packages/rdf.scm
index f10b530861..9a02a71d81 100644
--- a/gnu/packages/rdf.scm
+++ b/gnu/packages/rdf.scm
@@ -330,6 +330,49 @@ ideal (e.g. in LV2 implementations or embedded applications).")
(define-public python-rdflib
(package
(name "python-rdflib")
+ (version "7.0.0")
+ (source
+ (origin
+ (method url-fetch)
+ (uri (pypi-uri "rdflib" version))
+ (sha256
+ (base32
+ "1blmx4v003afr3l9qg84ymj0sldcbsr2dzdgq6w5k022d62yp5cr"))))
+ (build-system pyproject-build-system)
+ (arguments
+ '(#:phases
+ (modify-phases %standard-phases
+ (add-after 'unpack 'adjust-tests
+ (lambda _
+ (for-each delete-file
+ '(;; The tests in this file miss a test fixture.
+ ;; fixture 'no_cover' not found
+ "test/test_misc/test_plugins.py"
+ ;; These tests need internet access.
+ "test/jsonld/test_onedotone.py"
+ "test/test_examples.py"
+ "test/test_extras/test_infixowl/test_basic.py"
+ "test/test_extras/test_infixowl/test_context.py"
+ "test/test_sparql/test_service.py"))))
+ (replace 'check
+ (lambda* (#:key tests? #:allow-other-keys)
+ (when tests?
+ (invoke "pytest" "-vv" "test/")))))))
+ (native-inputs
+ (list python-pytest python-poetry-core))
+ (propagated-inputs
+ (list python-html5lib python-isodate python-pyparsing))
+ (home-page "https://github.com/RDFLib/rdflib")
+ (synopsis "Python RDF library")
+ (description
+ "RDFLib is a Python library for working with RDF, a simple yet
+powerful language for representing information.")
+ (license (license:non-copyleft "file://LICENSE"
+ "See LICENSE in the distribution."))))
+
+(define-public python-rdflib-6
+ (package
+ (name "python-rdflib")
(version "6.1.1")
(source
(origin