The Clar test framework has a bug whereby it skips the parsing phase on files with mtime=0. Reported upstream at . diff --git a/tests/generate.py b/tests/generate.py index b639c8f..111ca41 100644 --- a/tests/generate.py +++ b/tests/generate.py @@ -63,3 +63,3 @@ class Module(object): - self.mtime = 0 + self.mtime = None # Guix sets all file mtimes to '0' self.enabled = True '/'>cgit logo index : guix
Wojtek's customized Guix
aboutsummaryrefslogtreecommitdiff
path: root/gnu/packages/game-development.scm
AgeCommit message (Expand)Author
2024-09-13gnu: dhewm3: Update to 1.5.4....* gnu/packages/game-development.scm: (dhewm3): Update to 1.5.4. [arguments]: Set configure flags for 32-bit builds. Change-Id: I8db801b099910e60e85d0da7ddcc77654205107f Signed-off-by: Liliana Marie Prikler <liliana.prikler@gmail.com> James Smith
2024-09-07gnu: godot: Update to 4.3....* gnu/packages/game-development.scm (godot): Update to 4.3. [source]: Update snippet to preserve "ufbx". [arguments]<#:phases>: In scons-use-env phase change "env_base" to "env" to reflect upstream renaming. Change-Id: I479749a1b2f2acaa48f573d8e5edbb7b15f3797c John Kehayias
2024-09-02gnu: python-xsge: Update to 2021.10.11....* gnu/packages/game-development.scm (python-xsge): Update to 2021.10.11. [native-inputs]: Remove unzip. Change-Id: I2fd9530b61691adf5bb7c7b17c2060bf06d14c86 宋文武
2024-09-02gnu: python-sge: Update to 2.0.2....* gnu/packages/game-development.scm (python-sge): Update to 2.0.2. Change-Id: I7a0d1a64146368dd60fa665c44af79b8161eb29e 宋文武
2024-08-31gnu: game-development: Add 'bash' input for 'wrap-program'....It is required for cross-compilation. * gnu/packages/game-development.scm (godot-lts)[inputs]: Add 'bash-minimal'. (godot)[inputs]: Likewise. Signed-off-by: Maxim Cournoyer <maxim.cournoyer@gmail.com> Modified-by: Maxim Cournoyer <maxim.cournoyer@gmail.com> Change-Id: Ie92d21eb3b788ce0eff68548e11a8952b77e0e7b Maxime Devos
2024-08-31gnu: tsukundere: Import the correct set of modules....* gnu/packages/game-development.scm (tsukundere) [arguments] <modules>: Replace %default-gnu-imported-modules with %default-gnu-modules. Change-Id: I57fcb0ef5ef418e5bc5f6c8466f2ff1c5ffc7b37 Maxim Cournoyer
2024-08-31build-systems: gnu: Export %default-gnu-imported-modules and %default-gnu-mod......Until now users would have to cargo cult or inspect the private %default-modules variable of (guix build-systems gnu) to discover which modules to include when extending the used modules via the #:modules argument. The renaming was automated via the command: $ git grep -l %gnu-build-system-modules | xargs sed 's/%gnu-build-system-modules/%default-gnu-imported-modules/' -i * guix/build-system/gnu.scm (%gnu-build-system-modules): Rename to... (%default-gnu-imported-modules): ... this. (%default-modules): Rename to... (%default-gnu-modules): ... this. Export. (dist-package, gnu-build, gnu-cross-build): Adjust accordingly. Change-Id: Idef307fff13cb76f3182d782b26e1cd3a5c757ee Maxim Cournoyer
2024-08-28gnu: dds: Add missing header files....* gnu/packages/game-development.scm (dds)[arguments]<#:phases>: Also install header files. Change-Id: If3db20d8cb3530be16607d9e7c2a671dfff34439 Nicolas Goaziou