Make library/header paths visible to cmd/go script tests, which is necessary for
cgo/gccgo tests to work correctly
diff --git a/src/cmd/go/script_test.go b/src/cmd/go/script_test.go
index dfaa40548e..9d0f0e9bcd 100644
--- a/src/cmd/go/script_test.go
+++ b/src/cmd/go/script_test.go
@@ -100,6 +100,10 @@ const (
var extraEnvKeys = []string{
"SYSTEMROOT", // must be preserved on Windows to find DLLs; golang.org/issue/25210
"WINDIR", // must be preserved on Windows to be able to run PowerShell command; golang.org/issue/30711
+ "CPATH",
+ "C_INCLUDE_PATH",
+ "CPLUS_INCLUDE_PATH",
+ "LIBRARY_PATH",
"LD_LIBRARY_PATH", // must be preserved on Unix systems to find shared libraries
"CC", // don't lose user settings when invoking cgo
"GO_TESTING_GOTOOLS", // for gccgo testing
ko-scripts
gnu: ncdu: Update to 2.2.2....* gnu/packages/ncdu.scm (ncdu): Update to 2.2.2.
[native-inputs]: Switch from zig-0.9 to zig-0.10.
Efraim Flashner
2023-02-09
gnu: zig: Update to 0.10.1....* gnu/packages/zig.scm (zig-0.10): New variable.
(zig-0.9): Rename from zig. Inherit from zig-0.10.
(zig): Define as zig-0.10.
* gnu/packages/ncdu.scm (ncdu)[native-inputs]: Use zig-0.9.
* gnu/packages/zig-xyz.scm (zig-zls)[inputs]: Use zig-0.9.
Efraim Flashner
2022-12-11
gnu: ncdu: Use upstream name....* gnu/packages/ncdu.scm (ncdu-1): New variable, renamed from…
(ncdu): …this one, itself renamed from the old ncdu-2. Simple!
[name]: Drop suffix.
[properties]: Remove obsolete 'upstream-name.
(ncdu-2): Redefine as a DEPRECATED-PACKAGE alias of ncdu.