This patch allows us to use glibc's build system to build locales in a package separate from glibc. 1. Use 'localedef' from $PATH since we are not rebuilding it. 2. Use '--no-archive' to avoid building the big locale archive, and because the already-built 'localedef' would want to write it to '/run/current-system/locale', which is not possible. 3. Pass $(inst_complocaledir)/$$locale to install files in the right place, and because otherwise, 'localedef' fails with: "cannot write output files to `(null)'". --- glibc-2.22/localedata/Makefile 1970-01-01 01:00:00.000000000 +0100 +++ glibc-2.22/localedata/Makefile 2015-09-25 14:18:34.698941752 +0200 @@ -195,7 +195,7 @@ INSTALL-SUPPORTED-LOCALES=$(addprefix in # Sometimes the whole collection of locale files should be installed. LOCALEDEF=I18NPATH=. GCONV_PATH=$(common-objpfx)iconvdata LC_ALL=C \ -$(rtld-prefix) $(common-objpfx)locale/localedef + localedef --no-archive install-locales: $(INSTALL-SUPPORTED-LOCALES) install-locales-dir: @@ -212,7 +212,7 @@ $(INSTALL-SUPPORTED-LOCALES): install-lo input=`echo $$locale | sed 's/\([^.]*\)[^@]*\(.*\)/\1\2/'`; \ $(LOCALEDEF) --alias-file=../intl/locale.alias \ -i locales/$$input -c -f charmaps/$$charset \ - $(addprefix --prefix=,$(install_root)) $$locale \ + $(addprefix --prefix=,$(install_root)) $(inst_complocaledir)/$$locale \ && echo ' done'; \ tst-setlocale-ENV = LC_ALL=ja_JP.EUC-JP n='/guix/log/'>
diff options
context:
space:
mode:
Diffstat
-rw-r--r--gnu/packages/tex.scm20
1 files changed, 20 insertions, 0 deletions
diff --git a/gnu/packages/tex.scm b/gnu/packages/tex.scm
index bac6e847ac..639877124c 100644
--- a/gnu/packages/tex.scm
+++ b/gnu/packages/tex.scm
@@ -22687,6 +22687,26 @@ physics at the University of Wurzburg as a collection of macros and predefined
environments for quickly creating nice mathematical documents.")
(license license:lppl1.3+)))
+(define-public texlive-nddiss
+ (package
+ (name "texlive-nddiss")
+ (version (number->string %texlive-revision))
+ (source (texlive-origin
+ name version
+ (list "bibtex/bst/nddiss/" "doc/latex/nddiss/"
+ "source/latex/nddiss/" "tex/latex/nddiss/")
+ (base32
+ "131gzskjqhh5v677rxf2pap87jvi6jdznimqmql468y3pwc2zja0")))
+ (outputs '("out" "doc"))
+ (build-system texlive-build-system)
+ (home-page "https://ctan.org/pkg/nddiss")
+ (synopsis "Notre Dame Dissertation format class")
+ (description
+ "This class file conforms to the requirements of the Graduate School of
+the University of Notre Dame; with it a user can format a thesis or
+dissertation in LaTeX.")
+ (license license:lppl1.2+)))
+
(define-public texlive-nevelok
(package
(name "texlive-nevelok")