;;; GNU Guix --- Functional package management for GNU ;;; Copyright © 2014 John Darrington ;;; Copyright © 2018–2021 Tobias Geerinckx-Rice ;;; ;;; This file is part of GNU Guix. ;;; ;;; GNU Guix is free software; you can redistribute it and/or modify it ;;; under the terms of the GNU General Public License as published by ;;; the Free Software Foundation; either version 3 of the License, or (at ;;; your option) any later version. ;;; ;;; GNU Guix is distributed in the hope that it will be useful, but ;;; WITHOUT ANY WARRANTY; without even the implied warranty of ;;; MERCHANTABILITY or FITNESS FOR A PARTICULAR PURPOSE. See the ;;; GNU General Public License for more details. ;;; ;;; You should have received a copy of the GNU General Public License ;;; along with GNU Guix. If not, see . (define-module (gnu packages ncdu) #:use-module (gnu packages) #:use-module (gnu packages ncurses) #:use-module (guix licenses) #:use-module (guix packages) #:use-module (guix download) #:use-module (guix build-system gnu)) (define-public ncdu (package (name "ncdu") (version "1.16") (source (origin (method url-fetch) (uri (string-append "https://dev.yorhel.nl/download/ncdu-" version ".tar.gz")) (sha256 (base32 "1m0gk09jaz114piidiw8fkg0id5l6nhz1cg5nlaf1yl3l595g49b")))) (build-system gnu-build-system) (inputs (list ncurses)) (synopsis "Ncurses-based disk usage analyzer") (description "Ncdu is a disk usage analyzer with an ncurses interface, aimed to be run on a remote server where you don't have an entire graphical setup, but have to do with a simple SSH connection. ncdu aims to be fast, simple and easy to use, and should be able to run in any minimal POSIX-like environment with ncurses installed.") (license (x11-style (string-append "https://g.blicky.net/ncdu.git/plain/COPYING?id=v" version))) (home-page "https://dev.yorhel.nl/ncdu"))) ent'>
AgeCommit message (Expand)Author
2023-01-09daemon: Improve error message for wrong hash sizes....Ludovic Courtès
2022-12-18daemon: Make "opening file" error messages distinguishable....Ludovic Courtès
2022-10-17Revert "nix: Guard against removing temporary roots of living processes."...Ludovic Courtès
2022-10-07nix: Guard against removing temporary roots of living processes....Ludovic Courtès
2022-09-11daemon: Remove unused function findOutput....Maxime Devos
2022-09-11daemon: Remove unused function exportPaths....Maxime Devos
2022-09-11daemon: Remove unused function openStore....Maxime Devos
2022-06-05daemon: Quote consistently within a string....Tobias Geerinckx-Rice
2022-05-29daemon: Clarify ‘--check’ error when outputs are missing....Tobias Geerinckx-Rice
2022-05-18daemon: runChild() is forbidden to talk during environment set up...yarl-baudig@mailoo.org
2022-04-14daemon: Support systemd-style socket activation....Ludovic Courtès
2022-01-18daemon: Always default to gzip for log compression....Ludovic Courtès
2021-11-27daemon: Print the line whence we expect an integer....Tobias Geerinckx-Rice
2021-11-25daemon: Read substitute nar size as 'unsigned long long'....Ludovic Courtès
2021-11-25daemon: Read unsigned nar size and download size from substituter....Ludovic Courtès
2021-11-19daemon: Micro-optimize 'deletePath'....Ludovic Courtès
2021-11-16daemon: Do not deduplicate files smaller than 8 KiB....Ludovic Courtès