;;; GNU Guix --- Functional package management for GNU ;;; Copyright © 2013 John Darrington ;;; Copyright © 2015, 2019 Ludovic Courtès ;;; Copyright © 2018, 2020–2022 Tobias Geerinckx-Rice ;;; Copyright © 2018 Efraim Flashner ;;; ;;; This file is part of GNU Guix. ;;; ;;; GNU Guix is free software; you can redistribute it and/or modify it ;;; under the terms of the GNU General Public License as published by ;;; the Free Software Foundation; either version 3 of the License, or (at ;;; your option) any later version. ;;; ;;; GNU Guix is distributed in the hope that it will be useful, but ;;; WITHOUT ANY WARRANTY; without even the implied warranty of ;;; MERCHANTABILITY or FITNESS FOR A PARTICULAR PURPOSE. See the ;;; GNU General Public License for more details. ;;; ;;; You should have received a copy of the GNU General Public License ;;; along with GNU Guix. If not, see . (define-module (gnu packages mtools) #:use-module (guix licenses) #:use-module (guix packages) #:use-module (guix download) #:use-module (guix build-system gnu) #:use-module (gnu packages)) (define-public mtools (package (name "mtools") (version "4.0.42") (source (origin (method url-fetch) (uri (string-append "mirror://gnu/mtools/mtools-" version ".tar.bz2")) (sha256 (base32 "05fg5i8da5jdym3cq2939j7n3fqw4cz2riy1yci6pbw29pgdzgv4")) (patches (search-patches "mtools-mformat-uninitialized.patch")))) (build-system gnu-build-system) (home-page "https://www.gnu.org/software/mtools/") (synopsis "Access MS-DOS disks without mounting") (description "GNU Mtools is a set of utilities for accessing MS-DOS disks from a GNU or Unix system. It supports long file names and multiple disk formats. It also supports some FAT-specific features such as volume labels and FAT-specific file attributes.") (license gpl3+))) b96333d75cacb761640074405'>root/tests/accounts.scm
03-22 16:49:47 +0100'>2020-03-22
AgeCommit message (Expand)Author
Remove workaround for 'time-monotonic' in Guile 2.2.2....Ludovic Courtès
2020-03-22hydra: evaluate: Use 'with-build-handler'....Ludovic Courtès
2020-03-05hydra: Remove uses of _IOLBF....Ludovic Courtès
2019-12-01ci: Make sure the Guix checkout is the one providing Cuirass proc....Clément Lassieur
2019-01-06hydra: Compute jobs in an inferior....Ludovic Courtès
2019-01-06hydra: evaluate: Add the checkout to the store....Ludovic Courtès
2019-01-06hydra: Move job definitions to (gnu ci)....Ludovic Courtès
2018-12-29hydra: Use short timeouts for the QEMU jobs and system tests....Ludovic Courtès
2018-12-09hydra: Increase image sizes for USB image and Flash image....Danny Milosavljevic
2018-09-14hydra: Remove useless 'parameterize'....Clément Lassieur
2018-09-13hydra: Add support for manifests....Clément Lassieur
2018-06-15hydra: Make sure we add an absolute file name to the load path....Ludovic Courtès