;;; GNU Guix --- Functional package management for GNU ;;; Copyright © 2016 John Darrington ;;; ;;; This file is part of GNU Guix. ;;; ;;; GNU Guix is free software; you can redistribute it and/or modify it ;;; under the terms of the GNU General Public License as published by ;;; the Free Software Foundation; either version 3 of the License, or (at ;;; your option) any later version. ;;; ;;; GNU Guix is distributed in the hope that it will be useful, but ;;; WITHOUT ANY WARRANTY; without even the implied warranty of ;;; MERCHANTABILITY or FITNESS FOR A PARTICULAR PURPOSE. See the ;;; GNU General Public License for more details. ;;; ;;; You should have received a copy of the GNU General Public License ;;; along with GNU Guix. If not, see . (define-module (gnu packages marst) #:use-module (guix packages) #:use-module (guix licenses) #:use-module (guix download) #:use-module (gnu packages compression) #:use-module (guix build-system gnu)) (define-public marst (package (name "marst") (version "2.7") (source (origin (method url-fetch) (uri (string-append "mirror://gnu/" name "/" name "-" version ".tar.gz")) (sha256 (base32 "0l6swjy8fjrqw89ghc1vvakg21jmpfkpsw92yssrzkg3rg8vkrry")))) (build-system gnu-build-system) (home-page "https://www.gnu.org/software/marst/") (synopsis "Algol-to-C translator") (description "GNU MARST is an Algol-to-C translator. The package consists of the translator itself, a library that contains the necessary Algol 60 procedures, and a converter that converts existing Algol 60 programs from other representations to the MARST representation.") (license gpl3+))) tion value='grep'>log msg
AgeCommit message (Expand)Author
2024-02-22gnu: gnucobol: Remove pregenerated files.Efraim Flashner
2023-07-30gnu: gnucobol: Update to 3.2.Efraim Flashner
2022-10-14gnu: gnucobol: Use G-expressions.Efraim Flashner
2022-10-14gnu: gnucobol: Update description.Efraim Flashner
2021-12-30gnu: Capitalize beginning of synopsis.Vagrant Cascadian
2021-12-30gnu: Remove leading article from synopsis.Vagrant Cascadian
2021-12-13gnu: Simplify package inputs.Ludovic Courtès
2021-04-23gnu: cobol: Add missing inputs.Efraim Flashner
2021-04-23gnu: gnucobol: Update home-page.Efraim Flashner