aboutsummaryrefslogtreecommitdiff
path: root/gnu/packages/cobol.scm
diff options
context:
space:
mode:
authorEfraim Flashner <efraim@flashner.co.il>2021-04-23 10:10:59 +0300
committerEfraim Flashner <efraim@flashner.co.il>2021-04-23 17:21:19 +0300
commitabee44d2c31b3be79be68806d5721bf3edfa77e2 (patch)
tree4a8768227333a7043e1870d8214c7dfd6fd60982 /gnu/packages/cobol.scm
parent7af92387cf537bcf0d597a0d875e411da4218834 (diff)
downloadguix-abee44d2c31b3be79be68806d5721bf3edfa77e2.tar.gz
guix-abee44d2c31b3be79be68806d5721bf3edfa77e2.zip
gnu: cobol: Add missing inputs.
Reported by Simon Sobisch <simonsobisch@gnu.org>. * gnu/packages/cobol.scm (gnucobol)[inputs]: Add json-c, libxml2. Move newcob ... [native-inputs]: ... to here. [arguments]: Add configure-flag to set json-c cflags.
Diffstat (limited to 'gnu/packages/cobol.scm')
-rw-r--r--gnu/packages/cobol.scm23
1 files changed, 15 insertions, 8 deletions
diff --git a/gnu/packages/cobol.scm b/gnu/packages/cobol.scm
index 27fcc260dc..60af9f6a53 100644
--- a/gnu/packages/cobol.scm
+++ b/gnu/packages/cobol.scm
@@ -1,5 +1,5 @@
;;; GNU Guix --- Functional package management for GNU
-;;; Copyright © 2017, 2018 Efraim Flashner <efraim@flashner.co.il>
+;;; Copyright © 2017, 2018, 2021 Efraim Flashner <efraim@flashner.co.il>
;;;
;;; This file is part of GNU Guix.
;;;
@@ -25,7 +25,9 @@
#:use-module (gnu packages dbm)
#:use-module (gnu packages multiprecision)
#:use-module (gnu packages ncurses)
- #:use-module (gnu packages perl))
+ #:use-module (gnu packages perl)
+ #:use-module (gnu packages web)
+ #:use-module (gnu packages xml))
(define-public gnucobol
(package
@@ -43,7 +45,10 @@
(arguments
'(#:configure-flags (list (string-append "LDFLAGS=-Wl,-rpath="
(assoc-ref %outputs "out")
- "/lib"))
+ "/lib")
+ (string-append "JSON_C_CFLAGS=-I"
+ (assoc-ref %build-inputs "json-c")
+ "/include/json-c"))
#:phases
(modify-phases %standard-phases
(add-after 'unpack 'place-cobol85-test-suite
@@ -55,17 +60,19 @@
(lambda _ (setenv "TERM" "xterm-256color"))))
#:test-target "checkall"))
(native-inputs
- `(("perl" ,perl)))
- (inputs
- `(("bdb" ,bdb)
- ("gmp" ,gmp)
- ("ncurses" ,ncurses)
+ `(("perl" ,perl)
("newcob" ,(origin
(method url-fetch)
(uri "https://www.itl.nist.gov/div897/ctg/suites/newcob.val.Z")
(sha256
(base32
"1yb1plmv4firfnbb119r2vh1hay221w1ya34nyz0qwsxppfr56hy"))))))
+ (inputs
+ `(("bdb" ,bdb)
+ ("gmp" ,gmp)
+ ("json-c" ,json-c)
+ ("libxml2" ,libxml2)
+ ("ncurses" ,ncurses)))
(build-system gnu-build-system)
(home-page "https://www.gnu.org/software/gnucobol/")
(synopsis "A modern COBOL compiler")
t, trytond-account-de-skr03, trytond-account-deposit, trytond-account-dunning, trytond-account-dunning-email, trytond-account-dunning-fee, trytond-account-dunning-letter, trytond-account-eu, trytond-account-fr, trytond-account-invoice-correction, trytond-account-invoice-history, trytond-account-invoice-line-standalone, trytond-account-invoice-secondary-unit, trytond-account-payment-braintree, trytond-account-payment-sepa-cfonb, trytond-account-payment-stripe, trytond-account-statement-coda, trytond-account-statement-ofx, trytond-account-stock-landed-cost-weight, trytond-account-tax-cash, trytond-account-tax-rule-country, trytond-analytic-account, trytond-analytic-invoice, trytond-analytic-purchase, trytond-analytic-sale, trytond-attendance, trytond-authentication-sms, trytond-bank, trytond-carrier, trytond-commission, trytond-company, trytond-company-work-time, trytond-currency, trytond-customs, trytond-dashboard, trytond-edocument-uncefact, trytond-edocument-unece, trytond-gis, trytond-google-maps, trytond-marketing, trytond-marketing-email, trytond-party-avatar, trytond-party-relationship, trytond-party-siret, trytond-product, trytond-product-attribute, trytond-product-classification, trytond-product-classification-taxonomic, trytond-product-cost-fifo, trytond-product-cost-history, trytond-product-measurements, trytond-product-price-list, trytond-product-price-list-parent, trytond-production-outsourcing, trytond-production-routing, trytond-production-split, trytond-production-work, trytond-production-work-timesheet, trytond-project, trytond-project-plan, trytond-purchase-history, trytond-purchase-invoice-line-standalone, trytond-purchase-requisition, trytond-purchase-secondary-unit, trytond-purchase-shipment-cost, trytond-sale-advance-payment, trytond-sale-credit-limit, trytond-sale-extra, trytond-sale-history, trytond-sale-invoice-grouping, trytond-sale-opportunity, trytond-sale-price-list, trytond-sale-promotion, trytond-sale-promotion-coupon, trytond-sale-secondary-unit, trytond-sale-shipment-grouping, trytond-sale-shipment-tolerance, trytond-sale-stock-quantity, trytond-sale-subscription, trytond-sale-subscription-asset, trytond-sale-supply, trytond-stock-assign-manual, trytond-stock-consignment, trytond-stock-inventory-location, trytond-stock-location-move, trytond-stock-location-sequence, trytond-stock-lot, trytond-stock-lot-sled, trytond-stock-lot-unit, trytond-stock-package, trytond-stock-package-shipping-ups, trytond-stock-product-location, trytond-stock-secondary-unit, trytond-stock-split, trytond-stock-supply-day, trytond-stock-supply-forecast, trytond-stock-supply-production, trytond-timesheet, trytond-timesheet-cost, trytond-user-role, trytond-web-shop-vue-storefront-stripe, trytond-web-user): Update to 6.2.0. (trytond-web-shop): Update to 6.2.0. [native-inputs]: Add trytond-image. (trytond-account-es): Update to 6.2.0. [native-inputs]: Add trytond-sale-advance-payment. [propagated-inputs]: Add trytond-company, trytond-currency. (trytond-sale-gift-card): Update to 6.2.0. [native-inputs]: Add trytond-sale-point. (trytond-carrier-percentage, trytond-carrier-subdivision, trytond-carrier-weight, trytond-incoterm): Update to 6.2.0. [native-inputs]: Add trytond-stock-shipment-cost. (trytond-stock-shipment-cost): Update to 6.2.0. [propagated-inputs]: Add trytond-carrier. (trytond-stock-package-shipping): Update to 6.2.0. [propagated-inputs]: Remove trytond-sale-shipment-cost; add trytond-stock-shipment-cost. (trytond-account-asset, trytond-account-fr-chorus, trytond-account-invoice-stock, trytond-account-payment-clearing, trytond-account-product, trytond-account-statement-aeb43, trytond-account-statement-rule, trytond-account-stock-anglo-saxon, trytond-commission-waiting, trytond-ldap-authentication, trytond-marketing-automation, trytond-party, trytond-product-price-list-dates, trytond-production, trytond-project-revenue, trytond-purchase-amendment, trytond-purchase-price-list, trytond-purchase-request, trytond-purchase-request-quotation, trytond-sale-amendment, trytond-sale-complaint, trytond-sale-discount, trytond-sale-payment, trytond-sale-supply-drop-shipment, trytond-sale-supply-production, trytond-stock-forecast, trytond-stock-quantity-issue, trytond-stock-shipment-measurements, trytond-web-shortener): Update to 6.2.1. (trytond-product-cost-warehouse): Update to 6.2.1. [native-inputs]: Add trytond-account-invoice-stock. (trytond-web-shop-vue-storefront): Update to 6.2.1. [native-inputs]: Add trytond-product-image, trytond-stock-shipment-cost. (trytond-country): Update to 6.2.1. [propagated-inputs]: Remove python-pycountry; add python-pycountry@20.7.3. (trytond-account-invoice-defer, trytond-account-payment, trytond-account-payment-sepa, trytond-account-stock-landed-cost, trytond-notification-email, trytond-product-kit, trytond-sale-product-customer, trytond-sale-shipment-cost, trytond-stock-quantity-early-planning, trytond-stock-supply): Update to 6.2.2. (trytond-account-statement, trytond-account-stock-continental, trytond-project-invoice, trytond-purchase, trytond-stock-package-shipping-dpd): Update to 6.2.3. (python-proteus): Update to 6.2.3. [propagated-inputs]: Add python-defusedxml. (trytond-account-invoice, trytond-sale): Update to 6.2.4. (tryton, trytond-account, trytond-stock): Update to 6.2.7. (trytond): Update to 6.2.10. [propagated-inputs]: Add python-defusedxml. 2022-07-04gnu: Add trytond-stock-package-shipping-dpd.Hartmut Goebel * gnu/packages/tryton.scm (trytond-stock-package-shipping-dpd): New variable. 2022-07-04gnu: Add trytond-google-maps.Hartmut Goebel * gnu/packages/tryton.scm (trytond-google-maps): New variable. 2022-07-04gnu: Add trytond-gis.Hartmut Goebel * gnu/packages/tryton.scm (trytond-gis): New variable.