;;; GNU Guix --- Functional package management for GNU ;;; Copyright © 2012 Nikita Karetnikov ;;; ;;; This file is part of GNU Guix. ;;; ;;; GNU Guix is free software; you can redistribute it and/or modify it ;;; under the terms of the GNU General Public License as published by ;;; the Free Software Foundation; either version 3 of the License, or (at ;;; your option) any later version. ;;; ;;; GNU Guix is distributed in the hope that it will be useful, but ;;; WITHOUT ANY WARRANTY; without even the implied warranty of ;;; MERCHANTABILITY or FITNESS FOR A PARTICULAR PURPOSE. See the ;;; GNU General Public License for more details. ;;; ;;; You should have received a copy of the GNU General Public License ;;; along with GNU Guix. If not, see . (define-module (gnu packages less) #:use-module (guix licenses) #:use-module (gnu packages ncurses) #:use-module (guix packages) #:use-module (guix download) #:use-module (guix build-system gnu)) (define-public less (package (name "less") (version "481") (source (origin (method url-fetch) (uri (string-append "mirror://gnu/less/less-" version ".tar.gz")) (sha256 (base32 "19fxj0h10y5bhr3a1xa7kqvnwl44db3sdypz8jxl1q79yln8z8rz")))) (build-system gnu-build-system) (inputs `(("ncurses" ,ncurses))) (home-page "https://www.gnu.org/software/less/") (synopsis "Paginator for terminals") (description "GNU less is a pager, a program that allows you to view large amounts of text in page-sized chunks. Unlike traditional pagers, it allows both backwards and forwards movement through the document. It also does not have to read the entire input file before starting, so it starts faster than most text editors.") (license gpl3+))) ; some files are under GPLv2+ ='range'>range
AgeCommit message (Expand)Author
2024-08-18gnu: tigervnc-client, tigervnc-server: Update to 1.14.0....Tobias Geerinckx-Rice
2024-08-18gnu: tigervnc-client, tigervnc-server: Expand description....Tobias Geerinckx-Rice
2024-08-18gnu: tigervnc-server: Add own synopsis....Tobias Geerinckx-Rice
2024-07-30gnu: wayvnc: Fix cross-compiling....Zheng Junjie
2024-07-30gnu: wayvnc: Update to 0.8.0....Zheng Junjie
2024-07-30gnu: neatvnc: Update to 0.8.0....Zheng Junjie
2024-07-30gnu: Add wayvnc....kitzman
2024-07-30gnu: Add neatvnc....kitzman
2024-02-22gnu: tigervnc-client: Update to 1.13.1....Maxim Cournoyer
2023-12-08gnu: Make webkitgtk-next the new webkitgtk....Liliana Marie Prikler
2023-09-24gnu: remmina: Update to 1.4.32....Tobias Geerinckx-Rice
2023-08-18gnu: remmina: Build with librsvg-for-system....Efraim Flashner