aboutsummaryrefslogtreecommitdiff
path: root/gnu/packages/vnc.scm
diff options
context:
space:
mode:
authorTobias Geerinckx-Rice <me@tobias.gr>2024-08-18 02:00:00 +0200
committerTobias Geerinckx-Rice <me@tobias.gr>2024-08-18 02:00:00 +0200
commit620f935aa0feb425c37f3f0a9bc6eda6cdcbe4d0 (patch)
tree8cbf98de731f8a437ad25de29a80b77728940dc5 /gnu/packages/vnc.scm
parent3732257319e029dd4b0a5e388f35c18df52d71ba (diff)
downloadguix-620f935aa0feb425c37f3f0a9bc6eda6cdcbe4d0.tar.gz
guix-620f935aa0feb425c37f3f0a9bc6eda6cdcbe4d0.zip
gnu: tigervnc-client, tigervnc-server: Expand description.
* gnu/packages/vnc.scm (tigervnc-client)[synopsis, description]: Rewrite. (tigervnc-server)[description]: Likewise. Change-Id: I2a4e6309708068e9b27acfbd76c9dbdf1983446f
Diffstat (limited to 'gnu/packages/vnc.scm')
-rw-r--r--gnu/packages/vnc.scm39
1 files changed, 27 insertions, 12 deletions
diff --git a/gnu/packages/vnc.scm b/gnu/packages/vnc.scm
index 3a4b530535..1fbe089ce8 100644
--- a/gnu/packages/vnc.scm
+++ b/gnu/packages/vnc.scm
@@ -4,7 +4,7 @@
;;; Copyright © 2020 Hartmut Goebel <h.goebel@crazy-compilers.com>
;;; Copyright © 2020 Marius Bakke <marius@gnu.org>
;;; Copyright © 2020 Vincent Legoll <vincent.legoll@gmail.com>
-;;; Copyright © 2021, 2022 Tobias Geerinckx-Rice <me@tobias.gr>
+;;; Copyright © 2021, 2022, 2024 Tobias Geerinckx-Rice <me@tobias.gr>
;;; Copyright © 2022, 2024 Maxim Cournoyer <maxim.cournoyer@gmail.com>
;;; Copyright © 2022 Mehmet Tekman <mtekman89@gmail.com>
;;; Copyright @ 2022, Kitzman <kitzman@disroot.org>
@@ -206,13 +206,20 @@ RDP, VNC, SPICE, NX, XDMCP, SSH and EXEC network protocols are supported.")
libxdamage
pixman))
(home-page "https://tigervnc.org/")
- (synopsis "High-performance, platform-neutral
-implementation of VNC (client)")
- (description "TigerVNC is a client/server implementation of VNC (Virtual
-Network Computing). It provides enough performance to run even 3D and video
+ (synopsis "High-performance VNC remote desktop client")
+ (description "TigerVNC implements a @acronym{VNC, Virtual Network Computing}
+client and server. @dfn{VNC} is a remote display system that lets you view and
+interact with a virtual desktop environment running on another computer on the
+network. Client and server may be running on different operating systems and
+architectures.
+
+TigerVNC uses a variant of Tight encoding that is greatly accelerated by the use
+of the libjpeg-turbo JPEG codec and performs fast enough to run even 3D or video
applications. It also provides extensions for advanced authentication methods
-and TLS encryption. This package installs only the VNC client, the
-application which is needed to connect to VNC servers.")
+and @acronym{TLS, Transport-Level Security} encryption.
+
+This package installs only the VNC client (@command{vncviewer}), the application
+used to connect to VNC servers such as the tigervnc-server package.")
(license license:gpl2)))
(define %tigervnc-client-source (package-source tigervnc-client))
@@ -376,12 +383,20 @@ application which is needed to connect to VNC servers.")
(modify-inputs (package-propagated-inputs xorg-server)
(prepend xauth)))
(synopsis "High-performance VNC remote desktop server based on Xorg")
- (description "TigerVNC is a client/server implementation of VNC (Virtual
-Network Computing). It provides enough performance to run even 3D and video
+ (description "TigerVNC implements a @acronym{VNC, Virtual Network Computing}
+client and server. @dfn{VNC} is a remote display system that lets you view and
+interact with a virtual desktop environment running on another computer on the
+network. Client and server may be running on different operating systems and
+architectures.
+
+TigerVNC uses a variant of Tight encoding that is greatly accelerated by the use
+of the libjpeg-turbo JPEG codec and performs fast enough to run even 3D or video
applications. It also provides extensions for advanced authentication methods
-and TLS encryption. This package installs the VNC server, a program that will
-enable users with VNC clients to log into a graphical session on the machine
-where the server is installed.")))
+and @acronym{TLS, Transport-Level Security} encryption.
+
+This package installs the VNC server. Permitted users can log into a graphical
+session on the machine where the server is running, using a VNC client such as
+the tigervnc-client package.")))
(define-public turbovnc
(package