;;; GNU Guix --- Functional package management for GNU ;;; Copyright © 2019 Carl Dong ;;; ;;; This file is part of GNU Guix. ;;; ;;; GNU Guix is free software; you can redistribute it and/or modify it ;;; under the terms of the GNU General Public License as published by ;;; the Free Software Foundation; either version 3 of the License, or (at ;;; your option) any later version. ;;; ;;; GNU Guix is distributed in the hope that it will be useful, but ;;; WITHOUT ANY WARRANTY; without even the implied warranty of ;;; MERCHANTABILITY or FITNESS FOR A PARTICULAR PURPOSE. See the ;;; GNU General Public License for more details. ;;; ;;; You should have received a copy of the GNU General Public License ;;; along with GNU Guix. If not, see . (define-module (gnu packages installers) #:use-module ((guix licenses) #:prefix license:) #:use-module (gnu packages) #:use-module (gnu packages compression) #:use-module (gnu packages cross-base) #:use-module (gnu packages python-xyz) #:use-module (guix packages) #:use-module (guix download) #:use-module (guix build-system scons) #:use-module (guix utils)) (define (make-nsis machine target-arch nsis-target-type) (let* ((triplet (string-append machine "-" "w64-mingw32")) (xbinutils (cross-binutils triplet)) (xlibc (cross-libc triplet)) (xgcc (cross-gcc triplet #:libc x
aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
-rwxr-xr-xbuild.sh26
1 files changed, 13 insertions, 13 deletions
diff --git a/build.sh b/build.sh
index ec3a750..d3307d4 100755
--- a/build.sh
+++ b/build.sh
@@ -179,7 +179,7 @@ build_main() {
OPTIONSSCRIPTS="$(as_html_list $COMPUTED_SCRIPTS)"
for DIR in $(find $SCRIPTDIRS -type d); do
- mkdir -p $BUILDDIR/$DIR
+ mkdir -p "$BUILDDIR"/$DIR
done
CHROMIUM_KEY=''
@@ -221,15 +221,15 @@ s^_CHROMIUM_KEY_^$CHROMIUM_KEY^
s^_CHROMIUM_UPDATE_URL_^$CHROMIUM_UPDATE_URL^
s^_BGSCRIPTS_^$BGSCRIPTS^
s^_CONTENTSCRIPTS_^$CONTENTSCRIPTS^" \
- < manifest.json > $BUILDDIR/manifest.json
+ < manifest.json > "$BUILDDIR"/manifest.json
./process_html_file.sh html/display-panel.html |
sed "s^_POPUPSCRIPTS_^$POPUPSCRIPTS^" \
- > $BUILDDIR/html/display-panel.html
+ > "$BUILDDIR"/html/display-panel.html
./process_html_file.sh html/options.html |
sed "s^_OPTIONSSCRIPTS_^$OPTIONSSCRIPTS^" \
- > $BUILDDIR/html/options.html
+ > "$BUILDDIR"/html/options.html
for FILE in $SCRIPTS; do
FILEKEY=$(sanitize "$FILE")
@@ -255,16 +255,16 @@ fi
echo "
$(map_get EXPORTCODES $FILEKEY)
-})}).fun();") >