/gnu/packages/aux-files/chromium/

='alternate' title='Atom feed' href='https://git.koszko.org/guix/atom/gnu/packages?h=koszko' type='application/atom+xml'/>
aboutsummaryrefslogtreecommitdiff
path: root/gnu/packages
diff options
context:
space:
mode:
authorNicolas Goaziou <mail@nicolasgoaziou.fr>2023-05-18 13:49:23 +0200
committerNicolas Goaziou <mail@nicolasgoaziou.fr>2023-07-18 18:12:30 +0200
commitc448952f0af32aa40b4f6e555bff609beb929271 (patch)
treed6985a4e354a47ff6a37213e7aae00a2e46db8e8 /gnu/packages
parent936693c1fff5f581ead26899e4dd4d1f09b8629a (diff)
downloadguix-c448952f0af32aa40b4f6e555bff609beb929271.tar.gz
guix-c448952f0af32aa40b4f6e555bff609beb929271.zip
gnu: texlive-tabu: Remove SIMPLE-TEXLIVE-PACKAGE call.
* gnu/packages/tex.scm (texlive-tabu!): Remove SIMPLE-TEXLIVE-PACKAGE call. [propagated-inputs]: Add TEXLIVE-TOOLS. [description]: Shorten it and use proper Texinfo syntax.
Diffstat (limited to 'gnu/packages')
-rw-r--r--gnu/packages/tex.scm50
1 files changed, 21 insertions, 29 deletions
diff --git a/gnu/packages/tex.scm b/gnu/packages/tex.scm
index 7cfebfbd5b..d4cb32d63e 100644
--- a/gnu/packages/tex.scm
+++ b/gnu/packages/tex.scm
@@ -10974,35 +10974,27 @@ the engine in use.")
(define-deprecated-package texlive-generic-ifxetex texlive-iftex)
(define-public texlive-tabu
- (let ((template
- (simple-texlive-package
- "texlive-tabu"
- (list "doc/latex/tabu/"
- "source/latex/tabu/"
- "tex/latex/tabu/")
- (base32 "0mixyrqavipq4ni38z42x3579cdjbz54cp2qqb4q4yhfbl0a4pka"))))
- (package
- (inherit template)
- (outputs '("out" "doc"))
- (arguments
- (substitute-keyword-arguments (package-arguments template)
- ((#:tex-directory _ '())
- "latex/tabu")
- ((#:build-targets _ '())
- '(list "tabu.dtx"))))
- (propagated-inputs (list texlive-varwidth))
- (home-page "https://ctan.org/macros/latex/contrib/tabu")
- (synopsis "Flexible LaTeX tabulars")
- (description
- "The package provides an environment, tabu, which will make any sort of
-tabular, and an environment longtabu which provides the facilities of tabu in
-a modified longtable environment. The package requires array, xcolor for
-coloured rules in tables, and colortbl for coloured cells. The longtabu
-environment further requires that longtable be loaded. The package itself
-does not load any of these packages for the user. The tabu environment may be
-used in place of @code{tabular}, @code{tabular*} and @code{tabularx}
-environments, as well as the @code{array} environment in maths mode.")
- (license license:lppl1.3+))))
+ (package
+ (name "texlive-tabu")
+ (version (number->string %texlive-revision))
+ (source (texlive-origin
+ name version
+ (list "doc/latex/tabu/"
+ "source/latex/tabu/"
+ "tex/latex/tabu/")
+ (base32 "0mixyrqavipq4ni38z42x3579cdjbz54cp2qqb4q4yhfbl0a4pka")))
+ (outputs '("out" "doc"))
+ (build-system texlive-build-system)
+ (propagated-inputs
+ (list texlive-tools
+ texlive-varwidth))
+ (home-page "https://ctan.org/macros/latex/contrib/tabu")
+ (synopsis "Flexible LaTeX tabulars")
+ (description
+ "The package provides an environment, @code{tabu}, which will make any
+sort of tabular, and an environment @code{longtabu} which provides the
+facilities of @code{tabu} in a modified @code{longtable} environment.")
+ (license license:lppl1.3+)))
(define-public texlive-xkeyval
(package