aboutsummaryrefslogtreecommitdiff
path: root/gnu/packages
diff options
context:
space:
mode:
authorNicolas Goaziou <mail@nicolasgoaziou.fr>2023-05-18 13:45:41 +0200
committerNicolas Goaziou <mail@nicolasgoaziou.fr>2023-07-18 18:12:29 +0200
commit936693c1fff5f581ead26899e4dd4d1f09b8629a (patch)
tree3c015203456f4c6a6f733b13c9abc3edd5c0fc74 /gnu/packages
parent903f6db73b0cb4368fc20a81b39b8d9e6c110cbf (diff)
downloadguix-936693c1fff5f581ead26899e4dd4d1f09b8629a.tar.gz
guix-936693c1fff5f581ead26899e4dd4d1f09b8629a.zip
gnu: texlive-catchfile: Remove SIMPLE-TEXLIVE-PACKAGE call.
* gnu/packages/tex.scm (texlive-catchfile!): Remove SIMPLE-TEXLIVE-PACKAGE call. [propagated-inputs]: Add TEXLIVE-ETEXCMDS, TEXLIVE-INFWARERR, TEXLIVE-LTXCMDS.
Diffstat (limited to 'gnu/packages')
-rw-r--r--gnu/packages/tex.scm38
1 files changed, 20 insertions, 18 deletions
diff --git a/gnu/packages/tex.scm b/gnu/packages/tex.scm
index ba50ccd40d..7cfebfbd5b 100644
--- a/gnu/packages/tex.scm
+++ b/gnu/packages/tex.scm
@@ -6350,24 +6350,26 @@ for physicists.")
(license license:lppl)))
(define-public texlive-catchfile
- (let ((template (simple-texlive-package
- "texlive-catchfile"
- (list "/doc/latex/catchfile/"
- "/source/latex/catchfile/"
- "/tex/generic/catchfile/")
- (base32
- "1dpxy64hs0bjp8d2dmikflc995vazf7fi6z92w51fnj2fidgl8gx"))))
- (package
- (inherit template)
- (arguments
- (substitute-keyword-arguments (package-arguments template)
- ((#:tex-directory _ #t)
- "latex/catchfile")))
- (home-page "https://ctan.org/macros/latex/contrib/catchfile")
- (synopsis "Catch an external file into a macro")
- (description
- "Catchfile catches the contents of a file and puts it in a macro.")
- (license license:lppl1.3+))))
+ (package
+ (name "texlive-catchfile")
+ (version (number->string %texlive-revision))
+ (source (texlive-origin
+ name version
+ (list "doc/latex/catchfile/" "source/latex/catchfile/"
+ "tex/generic/catchfile/")
+ (base32
+ "1dpxy64hs0bjp8d2dmikflc995vazf7fi6z92w51fnj2fidgl8gx")))
+ (outputs '("out" "doc"))
+ (build-system texlive-build-system)
+ (propagated-inputs
+ (list texlive-etexcmds
+ texlive-infwarerr
+ texlive-ltxcmds))
+ (home-page "https://ctan.org/macros/latex/contrib/catchfile")
+ (synopsis "Catch an external file into a macro")
+ (description
+ "Catchfile catches the contents of a file and puts it in a macro.")
+ (license license:lppl1.3+)))
(define-public texlive-ddphonism
(package