aboutsummaryrefslogtreecommitdiff
path: root/tests/union.scm
diff options
context:
space:
mode:
Diffstat (limited to 'tests/union.scm')
0 files changed, 0 insertions, 0 deletions
td colspan='2' class='oid'>54b7f14956d0f5248bb62ead02ae0165c0320921 (diff)downloadguix-02a7a0caf4d159017755b9298f2f699fb0f46f46.tar.gz
guix-02a7a0caf4d159017755b9298f2f699fb0f46f46.zip
gnu: Add libnspsl.
* gnu/packages/web.scm (libnspsl): New variable.
Diffstat (limited to 'gnu')
-rw-r--r--gnu/packages/web.scm23
1 files changed, 23 insertions, 0 deletions
diff --git a/gnu/packages/web.scm b/gnu/packages/web.scm
index e858888b40..ffd3c11e21 100644
--- a/gnu/packages/web.scm
+++ b/gnu/packages/web.scm
@@ -4013,6 +4013,29 @@ C. It is developed as part of the NetSurf project.")
developed as part of the NetSurf project.")
(license l:expat)))
+(define-public libnspsl
+ (package
+ (name "libnspsl")
+ (version "0.1.0")
+ (source
+ (origin
+ (method url-fetch)
+ (uri (string-append "http://download.netsurf-browser.org/libs/releases/"
+ name "-" version "-src.tar.gz"))
+ (sha256
+ (base32
+ "0x3frscrp9bzxlm9ama5laxjr3zi8cg20r8lhsamw4x4zyyk145y"))))
+ (build-system gnu-build-system)
+ (native-inputs
+ `(("netsurf-buildsystem" ,netsurf-buildsystem)))
+ (arguments netsurf-buildsystem-arguments)
+ (home-page "http://www.netsurf-browser.org/")
+ (synopsis "Library to generate a static Public Suffix List")
+ (description
+ "Libnspsl is a library to generate a static code representation of the
+Public Suffix List. It is developed as part of the NetSurf project.")
+ (license l:expat)))
+
(define-public netsurf
(package
(name "netsurf")