aboutsummaryrefslogtreecommitdiff
path: root/guix/store.scm
diff options
context:
space:
mode:
Diffstat (limited to 'guix/store.scm')
-rw-r--r--guix/store.scm16
1 files changed, 4 insertions, 12 deletions
diff --git a/guix/store.scm b/guix/store.scm
index 9d706ae590..cf5d5eeccc 100644
--- a/guix/store.scm
+++ b/guix/store.scm
@@ -648,18 +648,10 @@ connection. Use with care."
(close-connection store)
(apply values results)))))
- (cond-expand
- (guile-3
- (with-exception-handler (lambda (exception)
- (close-connection store)
- (raise-exception exception))
- thunk))
- (else ;Guile 2.2
- (catch #t
- thunk
- (lambda (key . args)
- (close-connection store)
- (apply throw key args)))))))
+ (with-exception-handler (lambda (exception)
+ (close-connection store)
+ (raise-exception exception))
+ thunk)))
(define-syntax-rule (with-store store exp ...)
"Bind STORE to an open connection to the store and evaluate EXPs;
ail'>...* HACKING <Contributing>: Remove name of the manual from the item argument. * README <Installation>: Likewise. Mathieu Lirzin 2017-01-04doc: Add a Git hook that verifies signatures before pushing....* HACKING (Commit Access): Describe the pre-push Git hook. * etc/git/pre-push: New file. Leo Famulari 2016-07-24doc: Explain how to set up Git for signing....* HACKING (Commit Access): Give instructions on how to set up Git for signing. Ludovic Courtès 2016-07-14doc: Mention commit signatures in HACKING....* HACKING: Mention commit signatures. Leo Famulari 2015-06-14doc: Move most 'HACKING' informations into the manual....* HACKING (Contributing): New section. (Building from Git, The Perfect Setup, Coding Style, Submitting Patches): Move to ... * doc/guix.texi (Running Guix Before It Is Installed): Likewise. * doc/contributing.texi: ... here. New file. * doc.am (EXTRA_DIST): Use it. * README (Installation): Adapt to it. * configure.ac (DOT): Likewise. Mathieu Lirzin 2015-06-10doc: Add 'help2man' to HACKING....* HACKING: Mention 'help2man'. Alex Kost 2015-05-23doc: Add "Running Guix Before It Is Installed"....* doc/guix.texi (Running Guix Before It Is Installed): New node. (Packaging Guidelines): Refer to it. Ludovic Courtès 2015-02-26doc: Remove reference to git submodules in HACKING....* HACKING: Remove mention of git submodules. Mark H Weaver