aboutsummaryrefslogtreecommitdiff
path: root/gnu
diff options
context:
space:
mode:
Diffstat (limited to 'gnu')
-rw-r--r--gnu/packages/xml.scm4
1 files changed, 3 insertions, 1 deletions
diff --git a/gnu/packages/xml.scm b/gnu/packages/xml.scm
index 4a3936b66d..575cc016bb 100644
--- a/gnu/packages/xml.scm
+++ b/gnu/packages/xml.scm
@@ -1283,7 +1283,9 @@ UTF-8 and UTF-16 encoding.")
"tinyxmlparser.cpp" "tinystr.cpp"
"-o" "libtinyxml.so")))
(replace 'check
- (lambda _ (invoke "./xmltest")))
+ (lambda* (#:key tests? #:allow-other-keys)
+ (when tests?
+ (invoke "./xmltest"))))
(replace 'install
(lambda* (#:key outputs #:allow-other-keys)
(let* ((out (assoc-ref outputs "out"))