aboutsummaryrefslogtreecommitdiff
path: root/gnu
diff options
context:
space:
mode:
Diffstat (limited to 'gnu')
-rw-r--r--gnu/packages/golang.scm21
1 files changed, 20 insertions, 1 deletions
diff --git a/gnu/packages/golang.scm b/gnu/packages/golang.scm
index e8df68de18..7f563b2296 100644
--- a/gnu/packages/golang.scm
+++ b/gnu/packages/golang.scm
@@ -4092,6 +4092,24 @@ support for low-level interaction with the operating system.")
(home-page "https://go.googlesource.com/sys")
(license license:bsd-3))))
+;; XXX: This version is required for "go-github-com-quic-go-qtls-go1-20".
+(define-public go-golang-org-x-sys-0.8
+ (let ((commit "ca59edaa5a761e1d0ea91d6c07b063f85ef24f78")
+ (revision "0"))
+ (package
+ (inherit go-golang-org-x-sys)
+ (name "go-golang-org-x-sys")
+ (version (git-version "0.8.0" revision commit))
+ (source (origin
+ (method git-fetch)
+ (uri (git-reference
+ (url "https://go.googlesource.com/sys")
+ (commit commit)))
+ (file-name (git-file-name name version))
+ (sha256
+ (base32
+ "1p81niiin8dwyrjl2xsc95136w3vdw4kmj0w3mlh0vh5v134s4xq")))))))
+
(define-public go-golang-org-x-text
(package
(name "go-golang-org-x-text")
@@ -7711,7 +7729,8 @@ implementation of generics.")
(list
#:import-path "github.com/quic-go/qtls-go1-20"
#:go go-1.20))
- (propagated-inputs (list go-golang-org-x-crypto go-golang-org-x-sys))
+ (propagated-inputs (list go-golang-org-x-crypto
+ go-golang-org-x-sys-0.8))
(synopsis "TLS 1.3 for QUIC")
(description
"Go standard library TLS 1.3 implementation, modified for QUIC. For