aboutsummaryrefslogtreecommitdiff
path: root/gnu
diff options
context:
space:
mode:
Diffstat (limited to 'gnu')
-rw-r--r--gnu/packages/golang-web.scm35
1 files changed, 35 insertions, 0 deletions
diff --git a/gnu/packages/golang-web.scm b/gnu/packages/golang-web.scm
index 8f00b0e351..fbdef8a35f 100644
--- a/gnu/packages/golang-web.scm
+++ b/gnu/packages/golang-web.scm
@@ -270,6 +270,41 @@ the parse trees produced by the html package.")
connections from a single physical connection.")
(license license:expat)))
+(define-public go-github-com-aws-aws-lambda-go
+ (package
+ (name "go-github-com-aws-aws-lambda-go")
+ (version "1.47.0")
+ (source
+ (origin
+ (method git-fetch)
+ (uri (git-reference
+ (url "https://github.com/aws/aws-lambda-go")
+ (commit (string-append "v" version))))
+ (file-name (git-file-name name version))
+ (sha256
+ (base32 "0xki0n3va9nr6dmlgrb8zarkccx5jba6ig6g8zxcznw3rlllf1zv"))))
+ (build-system go-build-system)
+ (arguments
+ (list
+ #:import-path "github.com/aws/aws-lambda-go"
+ #:phases
+ #~(modify-phases %standard-phases
+ ;; XXX: Workaround for go-build-system's lack of Go modules support.
+ (delete 'build)
+ (replace 'check
+ (lambda* (#:key tests? import-path #:allow-other-keys)
+ (when tests?
+ (with-directory-excursion (string-append "src/" import-path)
+ (invoke "go" "test" "-v" "./..."))))))))
+ (native-inputs
+ (list go-github-com-stretchr-testify))
+ (home-page "https://github.com/aws/aws-lambda-go")
+ (synopsis "AWS Lambda for Go")
+ (description
+ "Libraries, samples, and tools to help Go developers develop AWS Lambda
+functions.")
+ (license license:asl2.0)))
+
(define-public go-github-com-aws-aws-sdk-go
(package
(name "go-github-com-aws-aws-sdk-go")
4dc875775305312513405fa396a06'>daemon: Add gzip log compression....Ludovic Courtès 2017-07-17daemon: Flush the sink upon 'exportPath' errors....Jan Nieuwenhuizen 2017-07-10daemon: Allow compilation with GCC 4.9....Ludovic Courtès 2017-06-22daemon: Set TCP_NODELAY and TCP_QUICKACK on remote sockets....Ludovic Courtès 2017-06-22daemon: '--listen' can be passed several times, can specify TCP endpoints....Ludovic Courtès 2017-06-04daemon: Add '--timeout' and '--max-silent-time'....Ludovic Courtès