aboutsummaryrefslogtreecommitdiff
path: root/gnu
diff options
context:
space:
mode:
Diffstat (limited to 'gnu')
-rw-r--r--gnu/packages/gnucash.scm5
-rw-r--r--gnu/packages/version-control.scm5
2 files changed, 6 insertions, 4 deletions
diff --git a/gnu/packages/gnucash.scm b/gnu/packages/gnucash.scm
index 2207dd3fae..84b244cdd9 100644
--- a/gnu/packages/gnucash.scm
+++ b/gnu/packages/gnucash.scm
@@ -27,6 +27,7 @@
#:use-module (guix download)
#:use-module (guix build-system gnu)
#:use-module (guix build-system cmake)
+ #:use-module ((guix records) #:select (this-record))
#:use-module (gnu packages)
#:use-module (gnu packages autotools)
#:use-module (gnu packages base)
@@ -165,14 +166,14 @@
,@(transitive-input-references
'inputs
(map (lambda (l)
- (assoc l (inputs)))
+ (assoc l (package-inputs this-record)))
'("perl-finance-quote"
"perl-date-manip"))))
(list
,@(transitive-input-references
'inputs
(map (lambda (l)
- (assoc l (inputs)))
+ (assoc l (package-inputs this-record)))
'("perl-finance-quote")))))))))
'("gnucash"
"gnc-fq-check"
diff --git a/gnu/packages/version-control.scm b/gnu/packages/version-control.scm
index 9a6f96ce14..fe9b64ba5c 100644
--- a/gnu/packages/version-control.scm
+++ b/gnu/packages/version-control.scm
@@ -51,6 +51,7 @@
#:use-module (guix build-system haskell)
#:use-module (guix build-system python)
#:use-module (guix build-system trivial)
+ #:use-module ((guix records) #:select (this-record))
#:use-module (gnu packages apr)
#:use-module (gnu packages autotools)
#:use-module (gnu packages documentation)
@@ -408,7 +409,7 @@ as well as the classic centralized workflow.")
,@(transitive-input-references
'inputs
(map (lambda (l)
- (assoc l (inputs)))
+ (assoc l (package-inputs this-record)))
'("perl-authen-sasl"
"perl-net-smtp-ssl"
"perl-io-socket-ssl")))))))
@@ -421,7 +422,7 @@ as well as the classic centralized workflow.")
,@(transitive-input-references
'inputs
(map (lambda (l)
- (assoc l (inputs)))
+ (assoc l (package-inputs this-record)))
'("perl-cgi")))))))
;; Tell 'git-submodule' where Perl is.