aboutsummaryrefslogtreecommitdiff
path: root/gnu
diff options
context:
space:
mode:
Diffstat (limited to 'gnu')
-rw-r--r--gnu/packages/file-systems.scm12
1 files changed, 11 insertions, 1 deletions
diff --git a/gnu/packages/file-systems.scm b/gnu/packages/file-systems.scm
index e7d78e41fb..198653c639 100644
--- a/gnu/packages/file-systems.scm
+++ b/gnu/packages/file-systems.scm
@@ -7,6 +7,7 @@
;;; Copyright © 2020 Raghav Gururajan <raghavgururajan@disroot.org>
;;; Copyright © 2020 Morgan Smith <Morgan.J.Smith@outlook.com>
;;; Copyright © 2021 raid5atemyhomework <raid5atemyhomework@protonmail.com>
+;;; Copyright © 2021 Stefan Reichör <stefan@xsteve.at>
;;;
;;; This file is part of GNU Guix.
;;;
@@ -1174,7 +1175,16 @@ local file system using FUSE.")
(build-system go-build-system)
(arguments
`(#:import-path "github.com/oniony/TMSU"
- #:unpack-path ".."))
+ #:unpack-path ".."
+ #:install-source? #f
+ #:phases
+ (modify-phases %standard-phases
+ (add-after 'install 'post-install
+ (lambda* (#:key outputs #:allow-other-keys)
+ (let ((out (assoc-ref outputs "out")))
+ ;; The go build system produces /bin/TMSU -> install as /bin/tmsu
+ (rename-file (string-append out "/bin/TMSU")
+ (string-append out "/bin/tmsu"))))))))
(inputs
`(("go-github-com-mattn-go-sqlite3" ,go-github-com-mattn-go-sqlite3)
("go-github-com-hanwen-fuse" ,go-github-com-hanwen-fuse)))
f54a0509ca5155'>gnu: calibre: Add exhaustive license list....Brendan Tildesley 2017-05-19gnu: calibre: Add missing dependencies....Brendan Tildesley 2017-05-19gnu: calibre: Unbundle chardet....Brendan Tildesley 2017-05-19gnu: calibre: Unbundle liberation fonts....Brendan Tildesley 2017-05-19gnu: calibre: Unbundle python2-markdown....Brendan Tildesley 2017-05-19gnu: calibre: Import unbundle feedparser patch from debian....Brendan Tildesley 2017-05-19gnu: calibre: Import dont-load-icons patch from debian....Brendan Tildesley 2017-05-19gnu: calibre: Update to 2.85.1....Brendan Tildesley 2017-01-04gnu: calibre: Update to 2.76.0....Alex Griffin 2016-12-12gnu: calibre: Update to 2.74.0....Efraim Flashner 2016-12-12gnu: calibre: Update qt dependancies....Efraim Flashner 2016-12-02gnu: calibre: Do not use python setuptools for building....Hartmut Goebel 2016-07-27gnu: calibre: Update to 2.63.0....Alex Griffin 2016-07-26gnu: calibre: Build with non-modular Qt....Andreas Enge 2016-07-19gnu: calibre: Update to 2.62.0....Efraim Flashner