aboutsummaryrefslogtreecommitdiff
path: root/gnu
diff options
context:
space:
mode:
Diffstat (limited to 'gnu')
-rw-r--r--gnu/packages/u-boot.scm10
1 files changed, 3 insertions, 7 deletions
diff --git a/gnu/packages/u-boot.scm b/gnu/packages/u-boot.scm
index e9a4b90941..7949d8a4c3 100644
--- a/gnu/packages/u-boot.scm
+++ b/gnu/packages/u-boot.scm
@@ -47,15 +47,11 @@
("flex" ,flex)))
(arguments
`(#:make-flags
- (list "CC=gcc" (string-append "PREFIX=" (assoc-ref %outputs "out")))
+ (list "CC=gcc"
+ (string-append "PREFIX=" (assoc-ref %outputs "out"))
+ "INSTALL=install")
#:phases
(modify-phases %standard-phases
- (add-after 'unpack 'patch-paths
- (lambda _
- (substitute* "Makefile"
- (("/usr/bin/install") "install"))
- (substitute* "Makefile"
- (("PREFIX = \\$\\(HOME\\)") ""))))
(delete 'configure))))
(home-page "https://www.devicetree.org")
(synopsis "Compiles device tree source files")