aboutsummaryrefslogtreecommitdiff
path: root/gnu
diff options
context:
space:
mode:
Diffstat (limited to 'gnu')
-rw-r--r--gnu/packages/databases.scm25
1 files changed, 13 insertions, 12 deletions
diff --git a/gnu/packages/databases.scm b/gnu/packages/databases.scm
index 68e1c2450e..9d1b9643c4 100644
--- a/gnu/packages/databases.scm
+++ b/gnu/packages/databases.scm
@@ -5033,18 +5033,19 @@ algorithm implementations.")
(name "python-pyarrow")
(build-system python-build-system)
(arguments
- '(#:tests? #f ; XXX There are no tests in the "python" directory
- #:phases
- (modify-phases %standard-phases
- (delete 'build) ; XXX the build is performed again during the install phase
- (add-after 'unpack 'enter-source-directory
- (lambda _ (chdir "python")))
- (add-before 'install 'set-pyarrow-build-options
- (lambda _
- (setenv "PYARROW_BUNDLE_ARROW_CPP_HEADERS" "0")
- (setenv "PYARROW_WITH_ORC" "1")
- (setenv "PYARROW_WITH_PARQUET" "1")
- (setenv "PYARROW_WITH_DATASET" "1"))))))
+ (list
+ #:tests? #f ; XXX There are no tests in the "python" directory
+ #:phases
+ #~(modify-phases %standard-phases
+ (delete 'build) ; XXX the build is performed again during the install phase
+ (add-after 'unpack 'enter-source-directory
+ (lambda _ (chdir "python")))
+ (add-before 'install 'set-pyarrow-build-options
+ (lambda _
+ (setenv "PYARROW_BUNDLE_ARROW_CPP_HEADERS" "0")
+ (setenv "PYARROW_WITH_ORC" "1")
+ (setenv "PYARROW_WITH_PARQUET" "1")
+ (setenv "PYARROW_WITH_DATASET" "1"))))))
(propagated-inputs
(list (list apache-arrow "lib")
(list apache-arrow "include")