aboutsummaryrefslogtreecommitdiff
path: root/gnu
diff options
context:
space:
mode:
Diffstat (limited to 'gnu')
-rw-r--r--gnu/packages/polkit.scm11
1 files changed, 7 insertions, 4 deletions
diff --git a/gnu/packages/polkit.scm b/gnu/packages/polkit.scm
index abbe878b79..620c22022f 100644
--- a/gnu/packages/polkit.scm
+++ b/gnu/packages/polkit.scm
@@ -82,11 +82,14 @@
#~(list "--sysconfdir=/etc"
"-Dman=true"
"-Dtests=true"
- ;; ERROR: Pkg-config binary for machine
- ;; MachineChoice.BUILD not found, giving up. Just
- ;; disable introspection for now.
+ ;; Work around cross-compilation failure. The build system
+ ;; probes for the _target_ gobject-introspection, but if we
+ ;; change it to native, Meson fails with:
+ ;; ERROR: Pkg-config binary for machine
+ ;; MachineChoice.BUILD not found, giving up.
+ ;; Just disable introspection for now.
#$@(if (%current-target-system)
- '("-Dos-type=unknown")
+ '("-Dintrospection=false")
'()))
#:phases
#~(modify-phases %standard-phases