aboutsummaryrefslogtreecommitdiff
path: root/gnu
diff options
context:
space:
mode:
Diffstat (limited to 'gnu')
-rw-r--r--gnu/packages/base.scm16
1 files changed, 16 insertions, 0 deletions
diff --git a/gnu/packages/base.scm b/gnu/packages/base.scm
index cbce8bd634..afdea31aad 100644
--- a/gnu/packages/base.scm
+++ b/gnu/packages/base.scm
@@ -549,6 +549,22 @@ used to apply commands with arbitrarily long arguments.")
;; here
((" test-tls\\$\\(EXEEXT\\) ") " ")))
'())
+ ,@(if (system-hurd64?)
+ '((substitute*
+ ;; These tests fail
+ '("tests/misc/sort-NaN-infloop.sh"
+ "tests/misc/wc-parallel.sh")
+ (("^#!.*" all)
+ (string-append all "exit 77;\n")))
+ (substitute* '("gnulib-tests/test-fdutimensat.c"
+ "gnulib-tests/test-futimens.c"
+ "gnulib-tests/test-linkat.c"
+ "gnulib-tests/test-renameat.c"
+ "gnulib-tests/test-renameatu.c"
+ "gnulib-tests/test-utimensat.c")
+ (("(^| )main *\\(.*" all)
+ (string-append all "{\n exit (77);//"))))
+ '())
(substitute* "Makefile.in"
;; fails on filesystems where inotify cannot be used,
;; more info in #47935