aboutsummaryrefslogtreecommitdiff
path: root/gnu
diff options
context:
space:
mode:
Diffstat (limited to 'gnu')
-rw-r--r--gnu/packages/android.scm17
1 files changed, 7 insertions, 10 deletions
diff --git a/gnu/packages/android.scm b/gnu/packages/android.scm
index 881b75d763..1a0e804a44 100644
--- a/gnu/packages/android.scm
+++ b/gnu/packages/android.scm
@@ -1195,25 +1195,22 @@ main repository.")
(define-public fdroidcl
(package
(name "fdroidcl")
- (version "0.5.0")
+ (version "0.7.0")
(source (origin
(method git-fetch)
(uri (git-reference
- (url "https://github.com/mvdan/fdroidcl")
- (commit (string-append "v" version))))
+ (url "https://github.com/mvdan/fdroidcl")
+ (commit (string-append "v" version))))
(file-name (git-file-name name version))
(sha256
- (base32 "1rxcdyy2j34z0ql9d62w7ivsch9xihjnpb1z9kgy9q46vl8zhhy0"))))
+ (base32
+ "1s3fszlyyab9gbdrg52zcbafsb1mgb770skg7b3gj7f3pzfnra5n"))))
(build-system go-build-system)
(arguments
`(#:import-path "mvdan.cc/fdroidcl"
- #:tests? #f ; TODO: Inputs missing.
+ #:tests? #f ;requires internet access
#:install-source? #f))
- (inputs
- (list go-github-com-kr-pretty))
- ;(native-inputs
- ; `(("go-github-com-rogpeppe-go-internal-testscript"
- ; ,go-github-com-rogpeppe-go-internal-testscript)))
+ (inputs (list go-github-com-kr-pretty go-github-com-schollz-progressbar-v3))
(synopsis "F-Droid desktop client")
(description
"While the Android client integrates with the system with regular update