aboutsummaryrefslogtreecommitdiff
path: root/gnu
diff options
context:
space:
mode:
Diffstat (limited to 'gnu')
-rw-r--r--gnu/packages/haskell-xyz.scm8
1 files changed, 6 insertions, 2 deletions
diff --git a/gnu/packages/haskell-xyz.scm b/gnu/packages/haskell-xyz.scm
index 685419e7e2..9b2ee0b0cc 100644
--- a/gnu/packages/haskell-xyz.scm
+++ b/gnu/packages/haskell-xyz.scm
@@ -8197,7 +8197,7 @@ specify refactorings without depending on GHC.")
(define-public ghc-reflection
(package
(name "ghc-reflection")
- (version "2.1.4")
+ (version "2.1.5")
(source
(origin
(method url-fetch)
@@ -8207,9 +8207,13 @@ specify refactorings without depending on GHC.")
".tar.gz"))
(sha256
(base32
- "0kf4a5ijw6jfnfibjcrpdy9vzh1n6v2pxia8dhyyqdissiwc8bzj"))))
+ "0xr947nj1vww5b8fwqmypxm3y3j5sxl4z8wnf834f83jzfzyjbi7"))))
(build-system haskell-build-system)
(inputs `(("ghc-tagged" ,ghc-tagged)))
+ (native-inputs
+ `(("ghc-hspec" ,ghc-hspec)
+ ("ghc-quickcheck" ,ghc-quickcheck)
+ ("hspec-discover" ,hspec-discover)))
(home-page "https://github.com/ekmett/reflection")
(synopsis "Reify arbitrary terms into types that can be reflected back
into terms")