aboutsummaryrefslogtreecommitdiff
path: root/gnu
diff options
context:
space:
mode:
Diffstat (limited to 'gnu')
-rw-r--r--gnu/packages/tex.scm58
1 files changed, 33 insertions, 25 deletions
diff --git a/gnu/packages/tex.scm b/gnu/packages/tex.scm
index 328fe62e29..99f3700ab2 100644
--- a/gnu/packages/tex.scm
+++ b/gnu/packages/tex.scm
@@ -2842,30 +2842,35 @@ tables.")
(define-public texlive-latex-xcolor
(deprecated-package "texlive-latex-xcolor" texlive-xcolor))
-(define-public texlive-latex-hyperref
- (package
- (name "texlive-latex-hyperref")
- (version "6.84a2")
- ;; The sources in the TeX Live SVN repository do not contain hluatex.dtx,
- ;; so we fetch the release from GitHub.
- (source (origin
- (method git-fetch)
- (uri (git-reference
- (url "https://github.com/ho-tex/hyperref")
- (commit (string-append "release-" version))))
- (file-name (git-file-name name version))
- (sha256
- (base32
- "186x6qmzyr51sfi9zkpgf5js8mn0qfryqdvwbfg58pyilw1l3vkm"))))
- (build-system texlive-build-system)
- (arguments '(#:tex-directory "latex/hyperref"))
- (propagated-inputs
- `(("texlive-latex-oberdiek" ,texlive-latex-oberdiek) ; for ltxcmds.sty
- ("texlive-latex-url" ,texlive-latex-url)))
- (home-page "https://www.ctan.org/pkg/hyperref")
- (synopsis "Extensive support for hypertext in LaTeX")
- (description
- "The @code{hyperref} package is used to handle cross-referencing commands
+(define-public texlive-hyperref
+ (let ((template (simple-texlive-package
+ "texlive-hyperref"
+ (list "/doc/latex/hyperref/"
+ "/source/latex/hyperref/"
+ ;; These files are not generated from the sources
+ "/tex/latex/hyperref/hylatex.ltx"
+ "/tex/latex/hyperref/minitoc-hyper.sty"
+ "/tex/latex/hyperref/ntheorem-hyper.sty"
+ "/tex/latex/hyperref/xr-hyper.sty")
+ (base32
+ "1074rnymyf7xj2ggajnijmy1p7avfjl216qyi86p38wg0qdf48zd"))))
+ (package
+ (inherit template)
+ (arguments
+ (substitute-keyword-arguments (package-arguments template)
+ ((#:tex-directory _ #t)
+ "latex/hyperref")
+ ((#:phases phases)
+ `(modify-phases ,phases
+ (add-after 'unpack 'chdir
+ (lambda _ (chdir "source/latex/hyperref") #t))))))
+ (propagated-inputs
+ `(("texlive-latex-oberdiek" ,texlive-latex-oberdiek) ; for ltxcmds.sty
+ ("texlive-latex-url" ,texlive-latex-url)))
+ (home-page "https://www.ctan.org/pkg/hyperref")
+ (synopsis "Extensive support for hypertext in LaTeX")
+ (description
+ "The @code{hyperref} package is used to handle cross-referencing commands
in LaTeX to produce hypertext links in the document. The package provides
backends for the @code{\\special} set defined for HyperTeX DVI processors; for
embedded @code{pdfmark} commands for processing by Acrobat
@@ -2873,7 +2878,10 @@ Distiller (@code{dvips} and Y&Y's @code{dvipsone}); for Y&Y's @code{dviwindo};
for PDF control within pdfTeX and @code{dvipdfm}; for TeX4ht; and for VTeX's
pdf and HTML backends. The package is distributed with the @code{backref} and
@code{nameref} packages, which make use of the facilities of @code{hyperref}.")
- (license license:lppl1.3+)))
+ (license license:lppl1.3+))))
+
+(define-public texlive-latex-hyperref
+ (deprecated-package "texlive-latex-hyperref" texlive-hyperref))
(define-public texlive-latex-oberdiek
(package
rvice-type and enable substitute server discover in guix-service-type. [<name-service-switch>]: Set it to %mdns-host-lookup-nss. Mathieu Othacehe 2020-12-11Revert "services: openssh: Warn about 'password-authentication?' default."...This reverts commit aecd2a13cbd8301d0fdeafcacbf69e12cc3f6138 for two reasons: 1. The warning would fire every time (gnu services ssh) is loaded; 2. There's still no clear consensus on the approach to follow as discussed in <https://issues.guix.gnu.org/44808>. Ludovic Courtès 2020-12-07services: openssh: Warn about 'password-authentication?' default....Fixes <https://bugs.gnu.org/44808>. Reported by Christopher Lemmer Webber <cwebber@dustycloud.org>. * gnu/services/ssh.scm (true-but-soon-false): New procedure. (<openssh-configuration>)[password-authentication?]: Change default to 'true-but-soon-false'. * gnu/installer/services.scm (%system-services): Explicitly set 'password-authentication?' to #f. Ludovic Courtès 2020-11-17installer: Fix device synchronization....Reported by Florian Pelz: https://lists.gnu.org/archive/html/guix-devel/2020-11/msg00326.html. * gnu/installer/utils.scm (call-with-time): New procedure, (let/time): new macro. * gnu/installer/parted.scm (with-delay-device-in-use?): Increase the retry count to 16. (non-install-devices): Remove the call to with-delay-device-in-use? as it doesn't return the expected result, and would block much longer now. (free-parted): Log the time required to sync each device. Mathieu Othacehe 2020-11-08installer: parted: Add debug output....* gnu/installer/parted.scm (mkpart): Log partition creation. Mathieu Othacehe 2020-11-07installer: parameters: Add a reboot button....Suggested by: zimoun <zimon.toutoune@gmail.com>. * gnu/installer/newt/parameters.scm (run-parameters-page): Add a reboot button. Mathieu Othacehe 2020-11-07installer: Edit partitioning warning message....* gnu/installer/newt/partition.scm (draw-formatting-page): Add an extra new line. Mathieu Othacehe 2020-11-07installer: Limit listbox height....Fixes: <https://issues.guix.gnu.org/44428>. * gnu/installer/newt.scm (init): Print screen size. * gnu/installer/newt/page.scm (default-listbox-height): New variable. (run-listbox-selection-page): Use it. * gnu/installer/newt/wifi.scm (wifi-listbox-height): Ditto. * gnu/installer/newt/network.scm (run-technology-page): Set the maximum listbox height to 5. * gnu/installer/newt/ethernet.scm (run-ethernet-page): Ditto. * gnu/installer/newt/final.scm (run-config-display-page): Change listbox height. * gnu/installer/newt/partition.scm (run-disk-page): Ditto. * gnu/installer/newt/welcome.scm (display-logo?): New procedure. (run-menu-page): Use it. * gnu/installer/steps.scm (%configuration-file-width): Remove it. Mathieu Othacehe 2020-11-02installer: Report to the user the formatted partitions....* gnu/installer/newt/partitions.scm (define-module): Use (ice-9 format). (draw-formatting-page): Add parameter partitions and provide the list of formatted partitions to the user. (run-partitioning-page): Provide user-partitions to draw-formatting-page. Miguel Ángel Arruga Vivas 2020-11-01installer: parted: Internationalize the partition handling code....* gnu/installer/parted.scm (user-partition-description): Use 'format' and 'G_' for i18n. Ludovic Courtès 2020-10-30installer: Use UUIDs in the 'swap-devices' field....Note: This change requires an updated 'guix' package that contains Linux-swap support in (gnu build file-systems). * gnu/installer/parted.scm (user-partitions->configuration): Use UUIDs in the 'swap-devices' field. * gnu/installer/newt/final.scm (run-final-page)[wait-for-clients]: New procedure. Use it. * gnu/installer/tests.scm (choose-partitioning): Wait for 'starting-final-step' message and move configuration file dialog handling to... (conclude-installation): ... here. Send over PORT the reply corresponding to 'starting-final-step'. * gnu/tests/install.scm (gui-test-program): When ENCRYPTED? is false, invoke 'swaplabel' in the marionette. (installation-target-os-for-gui-tests): When ENCRYPTED? is false, except a fixed UUID. Ludovic Courtès 2020-10-28installer: Log partition formatting....* gnu/installer/newt/partition.scm (run-partitioning-page): Add 'syslog' call. Ludovic Courtès 2020-10-23installer: Make the network management selection window tighter....* gnu/installer/newt/services.scm (run-network-management-page): Pass #:listbox-height. Ludovic Courtès 2020-10-19installer: Create bios_grub partition when it is needed....* gnu/installer/parted.scm (auto-partition!): Only check for ESP on EFI installations. Miguel Ángel Arruga Vivas 2020-10-13installer: Add Emacs EXWM desktop environment....Suggested by zenny via IRC. * gnu/installer/services.scm (%system-services): Add emacs, emacs-exwm, emacs-desktop-environment. * etc/release-manifest.scm (%system-packages): Likewise. * gnu/system/examples/lightweight-desktop.tmpl: Likewise. * gnu/tests/install.scm (installation-target-desktop-os-for-gui-tests) [packages]: Likewise * gnu/installer/newt/services.scm (run-desktop-environments-cbt-page): Make one entry taller. Jan (janneke) Nieuwenhuizen 2020-09-21installer: Rename RUN-PARTIONING-PAGE....* gnu/installer/newt/partition.scm (run-partioning-page): Rename to run-partitioning-page. Adjust all callers. Tobias Geerinckx-Rice 2020-09-21installer: Fix docstring typoes....* gnu/installer/connman.scm (connman-state, run-locale-page) (start-swapping, stop-swapping, run-installer-steps): Fix typo in docstring. Tobias Geerinckx-Rice 2020-09-10installer: final: Introduce call-with-mnt-container....* gnu/installer/final.scm (call-with-mnt-container): New procedure, (install-system): use it instead of call-with-container, to make sure that the container is not jailed. Mathieu Othacehe 2020-09-02installer: Run the installation inside a container....When the store overlay is mounted, other processes such as kmscon, udev and guix-daemon may open files from the store, preventing the underlying install support from being umounted. See: https://lists.gnu.org/archive/html/guix-devel/2018-12/msg00161.html. To avoid this situation, mount the store overlay inside a container, and run the installation from within that container. * gnu/build/shepherd.scm (fork+exec-command/container): New procedure. * gnu/services/base.scm (guix-shepherd-service): Support an optional PID argument passed to the "start" method. If that argument is passed, ensure that guix-daemon enters the given PID MNT namespace by using fork+exec-command/container procedure. * gnu/installer/final.scm (umount-cow-store): Remove it, (install-system): run the installation from within a container. * gnu/installer/newt/final.scm (run-install-shell): Remove the display hack. Mathieu Othacehe