aboutsummaryrefslogtreecommitdiff
path: root/gnu
diff options
context:
space:
mode:
Diffstat (limited to 'gnu')
-rw-r--r--gnu/system/install.scm7
1 files changed, 6 insertions, 1 deletions
diff --git a/gnu/system/install.scm b/gnu/system/install.scm
index 0cfc8fa5c9..6cde649995 100644
--- a/gnu/system/install.scm
+++ b/gnu/system/install.scm
@@ -237,7 +237,12 @@ the user's target storage device rather than on the RAM disk."
;; Minimal in-memory caching policy for nscd.
(list (nscd-cache (database 'hosts)
(positive-time-to-live (* 3600 12))
- (negative-time-to-live 20)
+
+ ;; Do not cache lookup failures at all since they are
+ ;; quite likely (for instance when someone tries to ping a
+ ;; host before networking is functional.)
+ (negative-time-to-live 0)
+
(persistent? #f)
(max-database-size (* 5 (expt 2 20)))))) ;5 MiB
a/gnu/packages/bioinformatics.scm b/gnu/packages/bioinformatics.scm
index 1f17c019f0..546be38ab0 100644
--- a/gnu/packages/bioinformatics.scm
+++ b/gnu/packages/bioinformatics.scm
@@ -2578,7 +2578,7 @@ accurately delineate genomic rearrangements throughout the genome.")
(define-public diamond
(package
(name "diamond")
- (version "0.9.22")
+ (version "0.9.30")
(source (origin
(method git-fetch)
(uri (git-reference
@@ -2587,7 +2587,7 @@ accurately delineate genomic rearrangements throughout the genome.")
(file-name (git-file-name name version))
(sha256
(base32
- "0bky78v79g3wmdpsd706cscckgw1v09fg8vdd0z8z0d5b97aj9zl"))))
+ "0k6f3kb6cniw11xw6763kkbs1sl0yack7xsy7q5fl5v170ssphq4"))))
(build-system cmake-build-system)
(arguments
'(#:tests? #f ; no "check" target