aboutsummaryrefslogtreecommitdiff
path: root/gnu
diff options
context:
space:
mode:
Diffstat (limited to 'gnu')
-rw-r--r--gnu/packages/perl.scm21
1 files changed, 21 insertions, 0 deletions
diff --git a/gnu/packages/perl.scm b/gnu/packages/perl.scm
index 1d986928fc..1f1ce340e0 100644
--- a/gnu/packages/perl.scm
+++ b/gnu/packages/perl.scm
@@ -195,6 +195,27 @@ code or from an external program. Optionally, output can be teed so that it
is captured while being passed through to the original file handles.")
(license asl2.0)))
+(define-public perl-class-data-inheritable
+ (package
+ (name "perl-class-data-inheritable")
+ (version "0.08")
+ (source
+ (origin
+ (method url-fetch)
+ (uri (string-append "mirror://cpan/authors/id/T/TM/TMTM/"
+ "Class-Data-Inheritable-" version ".tar.gz"))
+ (sha256
+ (base32
+ "0jpi38wy5xh6p1mg2cbyjjw76vgbccqp46685r27w8hmxb7gwrwr"))))
+ (build-system perl-build-system)
+ (home-page "http://search.cpan.org/dist/Class-Data-Inheritable")
+ (synopsis "Inheritable, overridable class data")
+ (description "Class::Data::Inheritable is for creating accessor/mutators
+to class data. That is, if you want to store something about your class as a
+whole (instead of about a single object). This data is then inherited by your
+subclasses and can be overriden.")
+ (license (package-license perl))))
+
(define-public perl-class-load
(package
(name "perl-class-load")
ass='msg-avail'>...Mathieu Othacehe 2020-04-26Merge branch 'master' into core-updatesMarius Bakke 2020-04-26vm: Remove unused import....Marius Bakke 2020-04-11vm: Make the device node procedure a parameter....Ludovic Courtès 2020-04-11vm: 'qemu-image' can pass options to the 'mkfs' command....Ludovic Courtès 2020-04-11vm: 'qemu-image' accepts a list of extra populate directives....Ludovic Courtès 2020-04-10vm: Use virtio network driver....Marius Bakke 2020-04-10vm: 'system-disk-image' honors #:substitutable? for ISO9660 images....Ludovic Courtès 2020-04-08vm: Allow images to be marked as non-substitutable....Ludovic Courtès 2020-03-26vm: Distinguish between success and failure of the guest code....Ludovic Courtès 2020-03-10vm: Compute UUIDs truly deterministically....Ludovic Courtès 2020-03-02file-systems: Add a 'file-system-device->string' procedure....Maxim Cournoyer 2019-12-18gnu: Remove uses of deprecated Qemu network configuration....Marius Bakke 2019-12-01system: vm: Support cross-compilation....Mathieu Othacehe 2019-11-22system: vm: Add arm64 support....Mathieu Othacehe 2019-11-18vm: Honor the VOLATILE? parameter when producing a system disk image....Maxim Cournoyer 2019-07-25maint: Switch to Guile-JSON 3.x....Ludovic Courtès 2019-06-17vm: 'system-docker-image' builds in a UTF-8 locale....Ludovic Courtès