aboutsummaryrefslogtreecommitdiff
path: root/gnu
diff options
context:
space:
mode:
Diffstat (limited to 'gnu')
-rw-r--r--gnu/packages/golang-xyz.scm27
1 files changed, 27 insertions, 0 deletions
diff --git a/gnu/packages/golang-xyz.scm b/gnu/packages/golang-xyz.scm
index becdef319b..b2079e1aa1 100644
--- a/gnu/packages/golang-xyz.scm
+++ b/gnu/packages/golang-xyz.scm
@@ -44,6 +44,7 @@
;;; Copyright © 2024 Jesse Eisses <jesse@eisses.email>
;;; Copyright © 2024 Luis Higino <luishenriquegh2701@gmail.com>
;;; Copyright © 2024 Troy Figiel <troy@troyfigiel.com>
+;;; Copyright © 2024 Spencer Peters <spencerpeters@protonmail.com>
;;;
;;; This file is part of GNU Guix.
;;;
@@ -6421,6 +6422,32 @@ reliable database for projects that don't require a full database server such as
Postgres or MySQL.")
(license license:expat)))
+(define-public go-go-senan-xyz-flagconf
+ (package
+ (name "go-go-senan-xyz-flagconf")
+ (version "0.1.9")
+ (source
+ (origin
+ (method git-fetch)
+ (uri (git-reference
+ (url "https://github.com/sentriz/flagconf")
+ (commit (string-append "v" version))))
+ (file-name (git-file-name name version))
+ (sha256
+ (base32 "1rms7hj1cdi5gfyhf1am1f8c4lq9ll4ashqi87yc6aq93gqgkag0"))))
+ (build-system go-build-system)
+ (arguments
+ (list
+ #:import-path "go.senan.xyz/flagconf"))
+ (propagated-inputs
+ (list go-github-com-rogpeppe-go-internal))
+ (home-page "https://go.senan.xyz/flagconf")
+ (synopsis "Extensions to Go's flag package")
+ (description
+ "Flagconf provides extensions to Go's flag package to support prefixed
+environment variables and a simple config file format.")
+ (license license:expat)))
+
(define-public go-go-uber-org-atomic
(package
(name "go-go-uber-org-atomic")