aboutsummaryrefslogtreecommitdiff
path: root/gnu
diff options
context:
space:
mode:
Diffstat (limited to 'gnu')
-rw-r--r--gnu/packages/gstreamer.scm4
1 files changed, 2 insertions, 2 deletions
diff --git a/gnu/packages/gstreamer.scm b/gnu/packages/gstreamer.scm
index 452e0d165d..310e4d1d56 100644
--- a/gnu/packages/gstreamer.scm
+++ b/gnu/packages/gstreamer.scm
@@ -417,7 +417,7 @@ compression formats through the use of the libav library.")
(define-public python-gst
(package
(name "python-gst")
- (version "1.8.2")
+ (version "1.10.0")
(source (origin
(method url-fetch)
(uri (string-append
@@ -425,7 +425,7 @@ compression formats through the use of the libav library.")
"gst-python-" version ".tar.xz"))
(sha256
(base32
- "15sdfa6lq5pswvi09vk51cs30yf8wr2rlm9myhb4q0c2jhiial2g"))))
+ "0hf71m0vqnd5sdj14li935xzzmqxh606qgw744a25w3vwj9v8nfy"))))
(build-system gnu-build-system)
(arguments
;; XXX: Factorize python-sitedir with python-build-system.
(method url-fetch) (uri (string-append "https://github.com/linux-rdma/infiniband-diags/releases" "/download/" version "/infiniband-diags-" version ".tar.gz")) (sha256 (base32 "11dbdnsx5hcvg6jh4ipm5j9wg420avpxw1jbsaj3zf4kwc5hw9id")))) (build-system gnu-build-system) (inputs (list rdma-core opensm glib)) (outputs '("out" "lib")) (native-inputs ;; FIXME: needs rst2man for man pages (list perl pkg-config)) (arguments (list #:configure-flags #~(list (string-append "CPPFLAGS=-I" #$(this-package-input "opensm") "/include/infiniband") (string-append "--with-perl-installdir=" #$output:lib "/lib/perl5/vendor_perl") "--disable-static") #:phases #~(modify-phases %standard-phases (add-after 'install 'licence (lambda* (#:key outputs #:allow-other-keys) (let ((doc (string-append (assoc-ref outputs "lib") "/share/doc"))) (mkdir-p doc) (install-file "COPYING" doc)))) (add-after 'install 'move-perl ;; Avoid perl in lib closure (lambda* (#:key outputs #:allow-other-keys) (let ((perlout (string-append (assoc-ref outputs "out") "/lib")) (perlin (string-append (assoc-ref outputs "lib") "/lib/perl5"))) (mkdir-p perlout) (rename-file perlin perlout))))))) (home-page "https://github.com/linux-rdma/infiniband-diags") (synopsis "Infiniband diagnostic tools") (description "This is a set of command-line utilities to help configure, debug, and maintain Infiniband (IB) fabrics. In addition to the utilities, a sub-library, @file{libibnetdisc}, is provided to scan an entire IB fabric and return data structures representing it. The interface to this library is not guaranteed to be stable.") (license (list gpl2 bsd-2)))) ; dual (define-public ibutils (package (name "ibutils") (version "1.5.7-0.2.gbd7e502") (source (origin (method url-fetch) (uri (string-append "https://www.openfabrics.org/downloads/ibutils/ibutils-" version ".tar.gz")) (sha256 (base32 "00x7v6cf8l5y6g9xwh1sg738ch42fhv19msx0h0090nhr0bv98v7")))) (build-system gnu-build-system) (inputs (list graphviz tcl tk infiniband-diags rdma-core opensm perl)) (native-inputs (list swig)) (arguments (list #:configure-flags #~(list (string-append "--with-osm=" #$(this-package-input "opensm")) (string-append "--with-tk-lib=" #$(this-package-input "tk") "/lib") "--disable-static" ;; Address this link error: ;; ld: .libs/ibis.o:/ibis/src/ibis.c:55: multiple definition of `IbisObj'; .libs/ibis_wrap.o:/ibis/src/ibis_wrap.c:3007: first defined here "CFLAGS=-O2 -g -fcommon"))) (synopsis "InfiniBand network utilities") (description "These command-line utilities allow for diagnosing and testing InfiniBand networks.") (home-page "https://www.openfabrics.org/downloads/ibutils/") (license bsd-2))) (define-public ucx (package (name "ucx") (version "1.17.0") (source (origin (method git-fetch) (uri (git-reference (url "https://github.com/openucx/ucx") (commit (string-append "v" version)))) (file-name (git-file-name name version)) (patches (search-patches "ucx-tcp-iface-ioctl.patch")) (sha256 (base32 "09182kx60kq7iyjyz3mpcrgp1mm0lnpc0f4hd4hlw5yyabkxrpa1")) (snippet ;; As seen in commit b0a275a5492125a13020cd095fe9934e0b5e7c6a. #~(begin (use-modules (guix build utils)) (substitute* "src/ucs/time/time.h" (("#include <limits.h>") "#include <limits.h>\n#include <math.h>")))))) (build-system gnu-build-system) (arguments (list ;; These are some of the flags found in ;; 'contrib/configure-release'. #:configure-flags #~(list "--disable-static" ;; XXX: Disable optimizations specific to the build ;; machine (AVX, etc.) There's apparently no way to ;; have them picked up at load time. "--disable-optimizations" "--disable-logging" "--disable-debug" "--disable-assertions" "--disable-params-check" (string-append "--with-verbs=" #$(this-package-input "rdma-core")) (string-append "--with-rdmacm=" #$(this-package-input "rdma-core"))) ;; Be verbose so that compiler flags are displayed. #:make-flags #~'("V=1"))) (native-inputs (list autoconf automake libtool pkg-config)) (inputs (list numactl rdma-core)) (synopsis "Optimized communication layer for message passing in HPC") (description "Unified Communication X (UCX) provides an optimized communication layer for message passing (MPI), portable global address space (PGAS) languages and run-time support libraries, as well as RPC and data-centric applications. UCX utilizes high-speed networks for inter-node communication, and shared memory mechanisms for efficient intra-node communication.") (home-page "https://www.openucx.org/") (license bsd-3) ;; <ucm/bistro/bistro.h> lists only PowerPC64, AArch64, RISC-V ;; and x86_64 as supported. (supported-systems '("x86_64-linux" "aarch64-linux" "powerpc64le-linux" "riscv64-linux"))))