aboutsummaryrefslogtreecommitdiff
path: root/gnu
diff options
context:
space:
mode:
Diffstat (limited to 'gnu')
-rw-r--r--gnu/packages/radio.scm12
1 files changed, 3 insertions, 9 deletions
diff --git a/gnu/packages/radio.scm b/gnu/packages/radio.scm
index ac9edf5bae..870f69dfed 100644
--- a/gnu/packages/radio.scm
+++ b/gnu/packages/radio.scm
@@ -1450,14 +1450,14 @@ NanoVNA vector network analyzers.")
(define-public qsstv
(package
(name "qsstv")
- (version "9.4.4")
+ (version "9.5.8")
(source
(origin
(method url-fetch)
(uri (string-append "http://users.telenet.be/on4qz/qsstv/downloads/"
"qsstv_" version ".tar.gz"))
(sha256
- (base32 "0f9hx6sy418cb23fadll298pqbc5l2lxsdivi4vgqbkvx7sw58zi"))))
+ (base32 "0s3sivc0xan6amibdiwfnknrl3248wzgy98w6gyxikl0qsjpygy0"))))
(build-system qt-build-system)
(native-inputs
(list pkg-config))
@@ -1474,16 +1474,10 @@ NanoVNA vector network analyzers.")
`(#:tests? #f ; No test suite.
#:phases
(modify-phases %standard-phases
- (add-after 'unpack 'fix-newer-hamlib-support
- (lambda _
- (substitute* "qsstv/rig/rigcontrol.cpp"
- (("FILPATHLEN")
- "HAMLIB_FILPATHLEN"))))
(replace 'configure
(lambda* (#:key outputs #:allow-other-keys)
(invoke "qmake"
- (string-append "PREFIX=" (assoc-ref outputs "out")))
- #t)))))
+ (string-append "PREFIX=" (assoc-ref outputs "out"))))))))
(home-page "http://users.telenet.be/on4qz/qsstv/")
(synopsis "Program for receiving and transmitting SSTV and HAMDRM")
(description
fine-configuration): Pattern match on ‘prefix’ literal. * tests/services/configuration.scm ("serialize-configuration with prefix"): New test. Signed-off-by: Ludovic Courtès <ludo@gnu.org> Xinglu Chen 2021-05-17services: configuration: Add a define-maybe/no-serialization syntax....Before this change, using define-maybe along define-configuration with the no-serialization syntactic keyword would result in the following warning: warning: possibly unbound variable `VARIABLE-NAME' This change introduces the define-maybe/no-serialization variant that does away with defining a serialization helper procedure, which makes it possible to avoid the above warning. * gnu/services/configuration.scm (define-maybe/no-serialization): New syntax. (define-maybe-helper): New procedure. (define-maybe): Define syntax using the above procedure. * tests/services/configuration.scm (tests): Fix module name. (custom-number-serializer): Do not print to standard output. (maybe-number?, serialize-maybe-number): New procedures defined via the define-maybe macro. (config-with-maybe-number): New configuration. (serialize-number): New procedure. ("maybe value serialization"): New test. (maybe-string?): New procedure defined via the define-maybe/no-serialization macro. (config-with-maybe-string/no-serialization): New configuration. ("maybe value without serialization no procedure bound"): New test. Maxim Cournoyer 2021-05-08services: configuration: Add tests....* tests/services/configuration.scm: New file. * Makefile.am (SCM_TESTS): Register it. Maxim Cournoyer 2021-02-12services: Add transmission-daemon service....* gnu/services/file-sharing.scm: New file. * gnu/local.mk (GNU_SYSTEM_MODULES): Add it. * po/packages/POTFILES.in: Add it. * tests/services/file-sharing.scm: New file. * Makefile.am (SCM_TESTS): Add it. * doc/guix.texi (File-Sharing Services): New section. Signed-off-by: 宋文武 <iyzsong@member.fsf.org> Simon South 2020-08-02services: Add zram-device-service....* gnu/services/linux.scm (<zram-device-configuration>): New record. (zram-device-service-type): New variable. * doc/guix.texi (Linux Services): Document it. * tests/services/linux.scm (zram-swap-device-test): New tests. Efraim Flashner 2020-01-31gnu: Add earlyoom-service-type....* gnu/services/linux.scm: New file. * tests/services/linux.scm: Add test. * Makefile.am (SCM_TESTS): Register test. * doc/guix.texi (Linux Services): Add a new section and document the new service and its configuration. Maxim Cournoyer