aboutsummaryrefslogtreecommitdiff
path: root/gnu
diff options
context:
space:
mode:
Diffstat (limited to 'gnu')
-rw-r--r--gnu/packages/maths.scm12
1 files changed, 9 insertions, 3 deletions
diff --git a/gnu/packages/maths.scm b/gnu/packages/maths.scm
index 4935f8019f..b5abc48b36 100644
--- a/gnu/packages/maths.scm
+++ b/gnu/packages/maths.scm
@@ -1491,10 +1491,16 @@ constant parts of it.")
;; Unfortunately, this is not supported on non-x86 architectures,
;; where it leads to failed builds.
,@(let ((system (or (%current-target-system) (%current-system))))
- (if (or (string-prefix? "x86_64" system)
+ (cond
+ ((or (string-prefix? "x86_64" system)
(string-prefix? "i686" system))
- '("DYNAMIC_ARCH=1")
- '())))
+ '("DYNAMIC_ARCH=1"))
+ ;; On MIPS we force the "SICORTEX" TARGET, as for the other
+ ;; two available MIPS targets special extended instructions
+ ;; for Loongson cores are used.
+ ((string-prefix? "mips" system)
+ '("TARGET=SICORTEX"))
+ (else '()))))
;; no configure script
#:phases (alist-delete 'configure %standard-phases)))
(inputs
/span>Ludovic Courtès 2020-06-25channels: Fix test for introductory commit signer....Ludovic Courtès 2020-06-16channels: Make 'validate-pull' call right after clone/pull....Ludovic Courtès 2020-06-16channels: 'latest-channel-instance' authenticates Git checkouts....Ludovic Courtès 2020-05-25channels: 'latest-channel-instances' guards against non-forward updates....Ludovic Courtès 2020-05-25git: 'update-cached-checkout' returns the commit relation....Ludovic Courtès 2020-05-07channels: Add mechanism to patch checkouts of the 'guix channel....Ludovic Courtès 2019-09-23channels: Allow news entries to refer to a tag....Ludovic Courtès 2019-09-23channels: Add support for a news file....Ludovic Courtès 2019-07-19channels: Always provide a <channel-metadata> record....Ludovic Courtès 2019-07-19channels: Strictly check the version of '.guix-channel'....Ludovic Courtès 2019-01-20inferior: 'gexp->derivation-in-inferior' honors EXP's load path....Ludovic Courtès 2019-01-20channels: Don't pull from the same channel more than once....Ludovic Courtès 2018-12-09guix: Add support for channel dependencies....Ricardo Wurmus