aboutsummaryrefslogtreecommitdiff
path: root/gnu
diff options
context:
space:
mode:
Diffstat (limited to 'gnu')
-rw-r--r--gnu/packages/emacs-xyz.scm4
1 files changed, 2 insertions, 2 deletions
diff --git a/gnu/packages/emacs-xyz.scm b/gnu/packages/emacs-xyz.scm
index fc249ff8c8..64c916dd4b 100644
--- a/gnu/packages/emacs-xyz.scm
+++ b/gnu/packages/emacs-xyz.scm
@@ -8563,7 +8563,7 @@ target will call @code{compile} on it.")
(define-public emacs-cider
(package
(name "emacs-cider")
- (version "0.25.0")
+ (version "0.26.0")
(source
(origin
(method git-fetch)
@@ -8572,7 +8572,7 @@ target will call @code{compile} on it.")
(commit (string-append "v" version))))
(file-name (git-file-name name version))
(sha256
- (base32 "1sdd7vzw948q01kc8im1asiq1j06q0mnn2s8kj83f8sbdnfy0qbk"))))
+ (base32 "1qwizvmm9ln75ph1jg2rfqv3hd9p4zaz8kp2i6yr3vq99c3a00i7"))))
(build-system emacs-build-system)
(arguments
'(#:exclude ;don't exclude 'cider-test.el'
173edc689a797355d9a16085d6e21bbed69'>gnu/packages/cran.scm
+++ b/gnu/packages/cran.scm
@@ -22631,3 +22631,35 @@ quantile regression, implemented using Barzilai-Borwein gradient descent with
a Huber regression warm start. Confidence intervals for regression
coefficients are constructed using multiplier bootstrap.")
(license license:gpl3)))
+
+(define-public r-fastshap
+ (package
+ (name "r-fastshap")
+ (version "0.0.5")
+ (source
+ (origin
+ (method url-fetch)
+ (uri (cran-uri "fastshap" version))
+ (sha256
+ (base32
+ "08f25ib5mry6h8lvj0g3clc9kfl5g2wdd8x8bw455wwmbcm6x5vg"))))
+ (properties `((upstream-name . "fastshap")))
+ (build-system r-build-system)
+ (propagated-inputs
+ `(("r-abind" ,r-abind)
+ ("r-ggplot2" ,r-ggplot2)
+ ("r-gridextra" ,r-gridextra)
+ ("r-matrixstats" ,r-matrixstats)
+ ("r-plyr" ,r-plyr)
+ ("r-rcpp" ,r-rcpp)
+ ("r-rcpparmadillo" ,r-rcpparmadillo)
+ ("r-tibble" ,r-tibble)))
+ (home-page "https://github.com/bgreenwell/fastshap")
+ (synopsis "Fast approximate Shapley values")
+ (description
+ "This package computes fast (relative to other implementations)
+approximate Shapley values for any supervised learning model. Shapley values
+help to explain the predictions from any black box model using ideas from game
+theory; see @url{Strumbel and Kononenko (2014),
+doi.org/10.1007/s10115-013-0679-x} for details.")
+ (license license:gpl2+)))