aboutsummaryrefslogtreecommitdiff
path: root/gnu
diff options
context:
space:
mode:
Diffstat (limited to 'gnu')
-rw-r--r--gnu/packages/linux.scm7
1 files changed, 5 insertions, 2 deletions
diff --git a/gnu/packages/linux.scm b/gnu/packages/linux.scm
index 3601744c51..3ca2a79666 100644
--- a/gnu/packages/linux.scm
+++ b/gnu/packages/linux.scm
@@ -1852,11 +1852,14 @@ GnuPG-based password manager like @code{pass}.")
#:phases #~(modify-phases %standard-phases
(delete 'configure)
(replace 'build
- (lambda _
+ (lambda* (#:key parallel-build? #:allow-other-keys)
(substitute* "Documentation/Makefile"
;; Remove problematic environment check script.
((".*scripts/sphinx-pre-install.*") ""))
- (invoke "make" "infodocs")))
+ (invoke "make" "infodocs"
+ "-j" (if parallel-build?
+ (number->string (parallel-job-count))
+ "1"))))
(replace 'install
(lambda _
(let* ((info-dir (string-append #$output "/share/info"))