aboutsummaryrefslogtreecommitdiff
path: root/gnu
diff options
context:
space:
mode:
Diffstat (limited to 'gnu')
-rw-r--r--gnu/packages/ruby.scm30
1 files changed, 30 insertions, 0 deletions
diff --git a/gnu/packages/ruby.scm b/gnu/packages/ruby.scm
index 7e02d417d2..c51a5f08e2 100644
--- a/gnu/packages/ruby.scm
+++ b/gnu/packages/ruby.scm
@@ -1862,6 +1862,36 @@ documentation for Ruby code.")
(home-page "http://github.com/voloko/sdoc")
(license license:expat)))
+(define-public ruby-tins
+ (package
+ (name "ruby-tins")
+ (version "1.7.0")
+ (source (origin
+ (method url-fetch)
+ (uri (rubygems-uri "tins" version))
+ (sha256
+ (base32
+ "1060h8dgnjl9az0sv1b74yrni8d4mh3x858wq6yfbfdf5dxrfl0a"))))
+ (build-system ruby-build-system)
+ ;; This gem needs gem-hadar at development time, but gem-hadar needs tins
+ ;; at runtime. To avoid the dependency on gem-hadar we disable rebuilding
+ ;; the gemspec.
+ (arguments
+ `(#:tests? #f ; there are no tests
+ #:phases
+ (modify-phases %standard-phases
+ (replace 'build
+ (lambda _
+ ;; "lib/spruz" is a symlink. Leaving it in the gemspec file
+ ;; causes an error.
+ (substitute* "tins.gemspec"
+ (("\"lib/spruz\", ") ""))
+ (zero? (system* "gem" "build" "tins.gemspec")))))))
+ (synopsis "Assorted tools for Ruby")
+ (description "Tins is a Ruby library providing assorted tools.")
+ (home-page "https://github.com/flori/tins")
+ (license license:expat)))
+
(define-public ruby-json
(package
(name "ruby-json")
b6c51c7604a'>system: Add u-boot-puma-rk3399....Vagrant Cascadian 2018-05-28file-systems: Remove 'title' field and add <file-system-label>....Ludovic Courtès 2018-05-18system: Add u-boot-pine64-plus installer....Vagrant Cascadian 2018-05-12bootloader: extlinux: Fix menu support with u-boot....Vagrant Cascadian 2018-05-11system: Add u-boot-novena installer....Vagrant Cascadian 2018-05-11system: Add wandboard installer....Vagrant Cascadian 2018-05-11system: Add mx6cuboxi installer....Vagrant Cascadian 2018-02-18gnu: Pass "--target=i386-pc" when installing GRUB for legacy BIOS....Ricardo Wurmus 2018-01-22system: Add A20 OLinuXino LIME installer....Danny Milosavljevic 2018-01-20system: Add Nintendo NES Classic Edition installer....Danny Milosavljevic 2018-01-20system: Add A20 OLinuXino MICRO installer....Danny Milosavljevic 2018-01-20system: Add A20 OLinuXino LIME2 installer....Danny Milosavljevic 2018-01-20system: Add Banana Pi M2 Ultra installer....Danny Milosavljevic 2017-12-15system: Add BeagleBone Black installer....Mathieu Othacehe 2017-12-15bootloader: Factorize write-file-on-device....Mathieu Othacehe 2017-12-04bootloader: extlinux: Stop using dd binary....Mathieu Othacehe 2017-11-23bootloader: extlinux: Fix device tree path....Mathieu Othacehe 2017-09-11system: Introduce a disjoint UUID type....Ludovic Courtès 2017-08-20gnu: grub-efi-bootloader: Specialize grub-install invocation....Andy Wingo 2017-08-03vm: Use grub-hybrid's grub-mkrescue....Danny Milosavljevic 2017-07-28bootloader: Use <menu-entry> for the bootloader side....Danny Milosavljevic 2017-07-15bootloader: Add u-boot....Danny Milosavljevic 2017-07-02gnu: Switch guile-cairo and dependents to Guile 2.2 again....Ludovic Courtès 2017-06-21bootloader: extlinux: Add extlinux-bootloader-gpt....Mathieu Othacehe 2017-06-08bootloader: Use menu-entry to define custom bootloader entries....Mathieu Othacehe 2017-05-21bootloader: extlinux: Add a warning message on top of generated conf file....Mathieu Othacehe 2017-05-18bootloader: extlinux: Remove syslinux-bootloader....Mathieu Othacehe 2017-05-18bootloader: extlinux: Remove undefined symbols from export list....Mathieu Othacehe 2017-05-16bootloader: Add extlinux support....Mathieu Othacehe