aboutsummaryrefslogtreecommitdiff
path: root/gnu
diff options
context:
space:
mode:
Diffstat (limited to 'gnu')
-rw-r--r--gnu/packages/base.scm6
-rw-r--r--gnu/packages/patches/glibc-ldd-x86_64.patch10
2 files changed, 14 insertions, 2 deletions
diff --git a/gnu/packages/base.scm b/gnu/packages/base.scm
index 3356c078f7..5a32e57535 100644
--- a/gnu/packages/base.scm
+++ b/gnu/packages/base.scm
@@ -409,7 +409,8 @@ BFD (Binary File Descriptor) library, `gprof', `nm', `strip', etc.")
(arguments
`(#:out-of-source? #t
- #:patches (list (assoc-ref %build-inputs "patch/ld.so.cache"))
+ #:patches (list (assoc-ref %build-inputs "patch/ld.so.cache")
+ (assoc-ref %build-inputs "patch/ldd"))
#:configure-flags
(list "--enable-add-ons"
"--sysconfdir=/etc"
@@ -422,7 +423,6 @@ BFD (Binary File Descriptor) library, `gprof', `nm', `strip', etc.")
(assoc-ref %outputs "locales")
"/share/locale")
-
(string-append "--with-headers="
(assoc-ref %build-inputs "linux-headers")
"/include")
@@ -496,6 +496,8 @@ BFD (Binary File Descriptor) library, `gprof', `nm', `strip', etc.")
(inputs `(("patch/ld.so.cache"
,(search-patch "glibc-no-ld-so-cache.patch"))
+ ("patch/ldd"
+ ,(search-patch "glibc-ldd-x86_64.patch"))
("static-bash" ,(static-package bash-light))))
(synopsis "The GNU C Library")
(description
diff --git a/gnu/packages/patches/glibc-ldd-x86_64.patch b/gnu/packages/patches/glibc-ldd-x86_64.patch
new file mode 100644
index 0000000000..b1b6d5a548
--- /dev/null
+++ b/gnu/packages/patches/glibc-ldd-x86_64.patch
@@ -0,0 +1,10 @@
+By default, 'RTDLLIST' in 'ldd' refers to 'lib64/ld-linux-x86-64.so', whereas
+it's in 'lib/' for us. This patch fixes that.
+
+--- glibc-2.17/sysdeps/unix/sysv/linux/x86_64/ldd-rewrite.sed 2012-12-25 04:02:13.000000000 +0100
++++ glibc-2.17/sysdeps/unix/sysv/linux/x86_64/ldd-rewrite.sed 2013-09-15 23:08:03.000000000 +0200
+@@ -1,3 +1,3 @@
+ /LD_TRACE_LOADED_OBJECTS=1/a\
+ add_env="$add_env LD_LIBRARY_VERSION=\\$verify_out"
+-s_^\(RTLDLIST=\)\(.*lib\)\(\|64\|x32\)\(/[^/]*\)\(-x86-64\|-x32\)\(\.so\.[0-9.]*\)[ ]*$_\1"\2\4\6 \264\4-x86-64\6 \2x32\4-x32\6"_
++s_^\(RTLDLIST=\)\(.*lib\)\(\|64\|x32\)\(/[^/]*\)\(-x86-64\|-x32\)\(\.so\.[0-9.]*\)[ ]*$_\1"\2\4\6 \2\4-x86-64\6 \2x32\4-x32\6"_
n class='msg-avail'>...Lars-Dominik Braun 2021-06-06gnu: xf86-input-libinput: Update to 1.0.1....Matthew James Kraai 2021-06-06gnu: xf86-input-libinput: Fix licence information....Tobias Geerinckx-Rice 2021-06-06gnu: xterm: Update to 367....Matthew James Kraai 2021-06-05gnu: console-setup: Update to 1.203....Tobias Geerinckx-Rice 2021-05-23gnu: libx11: Update replacement to 1.7.1 [fixes CVE-2021-31535]....Marius Bakke 2021-04-27gnu: xorg-server: Update to 1.20.11 [fixes CVE-2021-3472]....nixo 2021-03-17gnu: Use PACKAGE/INHERIT in more places....Mark H Weaver 2021-03-15gnu: xterm: Fix uxterm in pure environments....Tobias Geerinckx-Rice 2021-03-13gnu: console-setup: Update to 1.201....Tobias Geerinckx-Rice 2021-03-11gnu: libx11: Update to 1.6.12 [fixes CVE-2020-14363]....Léo Le Bouter 2021-03-09gnu: xvfb-run: Fix syntax error....Ludovic Courtès 2021-03-09gnu: xvfb-run: Add man page licence....Tobias Geerinckx-Rice 2021-03-09gnu: Add xvfb-run....Tobias Geerinckx-Rice 2021-03-07gnu: xf86-video-nouveau: Update to 1.0.17....Tobias Geerinckx-Rice 2021-02-12gnu: xterm: Update to 366 [fixes CVE-2021-27135]....Leo Famulari 2021-01-25Merge branch 'master' into stagingLeo Famulari 2021-01-19gnu: xpra: Add more encoding options....Michael Rohleder 2021-01-19gnu: xpra: Update to 4.0.6....Michael Rohleder 2021-01-10Merge branch 'master' into stagingEfraim Flashner 2021-01-03gnu: xterm: Update to 363....Tobias Geerinckx-Rice