aboutsummaryrefslogtreecommitdiff
path: root/gnu
diff options
context:
space:
mode:
Diffstat (limited to 'gnu')
-rw-r--r--gnu/packages/web.scm22
1 files changed, 22 insertions, 0 deletions
diff --git a/gnu/packages/web.scm b/gnu/packages/web.scm
index 82d768e630..aecdd21950 100644
--- a/gnu/packages/web.scm
+++ b/gnu/packages/web.scm
@@ -1192,6 +1192,28 @@ which are changed by reverse-proxy. You can specify the reverse proxy address
and stop fake requests using 'enable_if' directive in your app.psgi.")
(license (package-license perl))))
+(define-public perl-plack-test-externalserver
+ (package
+ (name "perl-plack-test-externalserver")
+ (version "0.01")
+ (source
+ (origin
+ (method url-fetch)
+ (uri (string-append "mirror://cpan/authors/id/F/FL/FLORA/"
+ "Plack-Test-ExternalServer-" version ".tar.gz"))
+ (sha256
+ (base32
+ "1dbg1p3rgvvbkkpvca5jlc2mzx8iqyiybk88al93pvbca65h1g7h"))))
+ (build-system perl-build-system)
+ (propagated-inputs
+ `(("perl-plack" ,perl-plack)))
+ (home-page "http://search.cpan.org/dist/Plack-Test-ExternalServer")
+ (synopsis "Run HTTP tests on external live servers")
+ (description "This module allows your to run your Plack::Test tests
+against an external server instead of just against a local application through
+either mocked HTTP or a locally spawned server.")
+ (license (package-license perl))))
+
(define-public perl-test-tcp
(package
(name "perl-test-tcp")
onfig)....Mathieu Othacehe 2020-06-16etc: Add committer script....Ricardo Wurmus 2020-05-28maint: Check whether Guile-Gcrypt is recent enough....Ludovic Courtès 2020-05-14etc: indent-code.el: Use the --quick option....Maxim Cournoyer 2020-04-23build: Don't build man pages when cross-compiling....Ludovic Courtès 2020-03-11build: Require Guile 2.2.3 or later....Ludovic Courtès 2020-01-17build: Allow builds with Guile 3.0....Ludovic Courtès 2019-11-09build: Warn about etc/indent-code.el when Emacs is absent....zimoun 2019-07-25maint: Switch to Guile-JSON 3.x....Ludovic Courtès 2019-05-06Add (guix lzlib)....Pierre Neidhardt 2019-04-17build: No longer substitute 'LIBGCRYPT'....Ludovic Courtès