aboutsummaryrefslogtreecommitdiff
path: root/gnu
diff options
context:
space:
mode:
Diffstat (limited to 'gnu')
-rw-r--r--gnu/packages/terminals.scm4
1 files changed, 2 insertions, 2 deletions
diff --git a/gnu/packages/terminals.scm b/gnu/packages/terminals.scm
index 4ad21fd05a..4dfc51b283 100644
--- a/gnu/packages/terminals.scm
+++ b/gnu/packages/terminals.scm
@@ -835,7 +835,7 @@ eye-candy, customizable, and reasonably lightweight.")
(define-public foot
(package
(name "foot")
- (version "1.11.0")
+ (version "1.12.1")
(home-page "https://codeberg.org/dnkl/foot")
(source (origin
(method git-fetch)
@@ -843,7 +843,7 @@ eye-candy, customizable, and reasonably lightweight.")
(file-name (git-file-name name version))
(sha256
(base32
- "1d9bk8lhmw5lc8k0mw80g0vbwgxyh3gw5c7ppy3sir07s9y0y0fn"))))
+ "14jqs4sarxbrgi5pxz0afqa9jxq90cb5ayqd21qj2n65whqa5bpk"))))
(build-system meson-build-system)
(arguments
`(;; Using a "release" build is recommended both for performance, and
f not, see <http://www.gnu.org/licenses/>. (define-module (gnu services spice) #:use-module (gnu packages spice) #:use-module (gnu services) #:use-module (gnu services shepherd) #:use-module (guix gexp) #:use-module (guix records) #:export (spice-vdagent-configuration spice-vdagent-configuration? spice-vdagent-service-type spice-vdagent-service)) (define-record-type* <spice-vdagent-configuration> spice-vdagent-configuration make-spice-vdagent-configuration spice-vdagent-configuration? (spice-vdagent spice-vdagent-configuration-spice-vdagent (default spice-vdagent))) (define (spice-vdagent-activation config) "Return the activation gexp for CONFIG." #~(begin (use-modules (guix build utils)) (mkdir-p "/var/run/spice-vdagentd"))) (define (spice-vdagent-shepherd-service config) "Return a <shepherd-service> for spice-vdagentd with CONFIG." (define spice-vdagent (spice-vdagent-configuration-spice-vdagent config)) (define spice-vdagentd-command (list (file-append spice-vdagent "/sbin/spice-vdagentd") "-x")) (list (shepherd-service (documentation "Spice vdagentd service") (requirement '(udev)) (provision '(spice-vdagentd)) (start #~(make-forkexec-constructor #$@spice-vdagentd-command)) (stop #~(make-kill-destructor))))) (define spice-vdagent-profile (compose list spice-vdagent-configuration-spice-vdagent)) (define spice-vdagent-service-type (service-type (name 'spice-vdagent) (extensions (list (service-extension shepherd-root-service-type spice-vdagent-shepherd-service) (service-extension activation-service-type spice-vdagent-activation) (service-extension profile-service-type spice-vdagent-profile))))) (define* (spice-vdagent-service #:optional (config (spice-vdagent-configuration))) "Start the @command{vdagentd} and @command{vdagent} deamons from @var{spice-vdagent} to enable guest window resizing and clipboard sharing." (service spice-vdagent-service-type config))