aboutsummaryrefslogtreecommitdiff
path: root/gnu
diff options
context:
space:
mode:
Diffstat (limited to 'gnu')
-rw-r--r--gnu/packages/python-web.scm32
1 files changed, 0 insertions, 32 deletions
diff --git a/gnu/packages/python-web.scm b/gnu/packages/python-web.scm
index 304d01bfff..069b9ec4ca 100644
--- a/gnu/packages/python-web.scm
+++ b/gnu/packages/python-web.scm
@@ -4980,38 +4980,6 @@ Betamax that may possibly end up in the main package.")
"S3transfer is a Python library for managing Amazon S3 transfers.")
(license license:asl2.0)))
-(define-public python-flask-jwt
- (package
- (name "python-flask-jwt")
- (version "0.3.2")
- (source (origin
- (method url-fetch)
- (uri (pypi-uri "Flask-JWT" version))
- (sha256
- (base32
- "1bfh7cr0sf65rn4h1q67472y6ml9s8c4k0xxfhrwvwg0plpngh29"))))
- (build-system pyproject-build-system)
- (arguments
- (list
- #:phases
- '(modify-phases %standard-phases
- (add-after 'unpack 'compatibility
- (lambda _
- (substitute* "setup.cfg"
- (("\\[pytest\\]") "[tool:pytest]"))
- (substitute* "requirements.txt"
- (("PyJWT>=1.4.0,<1.5.0") "PyJWT>=2.0.0"))
- (substitute* '("tests/test_jwt.py"
- "flask_jwt/__init__.py")
- (("access_token.decode\\('utf-8'\\)") "access_token")))))))
- (propagated-inputs (list python-flask python-pyjwt))
- (native-inputs (list python-pytest python-setuptools python-wheel))
- (home-page "https://github.com/mattupstate/flask-jwt")
- (synopsis "JWT token authentication for Flask apps")
- (description "This package implements JWT token authentication for Flask
-apps.")
- (license license:expat)))
-
(define-public python-flask-restful
(package
(name "python-flask-restful")