aboutsummaryrefslogtreecommitdiff
path: root/gnu
diff options
context:
space:
mode:
Diffstat (limited to 'gnu')
-rw-r--r--gnu/packages/fcitx5.scm11
1 files changed, 9 insertions, 2 deletions
diff --git a/gnu/packages/fcitx5.scm b/gnu/packages/fcitx5.scm
index aba0be21e7..c555b8ab84 100644
--- a/gnu/packages/fcitx5.scm
+++ b/gnu/packages/fcitx5.scm
@@ -3,6 +3,7 @@
;;; Copyright © 2021 Tobias Geerinckx-Rice <me@tobias.gr>
;;; Copyright © 2022 Dominic Martinez <dom@dominicm.dev>
;;; Copyright © 2022 dan <i@dan.games>
+;;; Copyright © 2024 Zheng Junjie <873216071@qq.com>
;;;
;;; This file is part of GNU Guix.
;;;
@@ -320,12 +321,18 @@ IM module for GTK+3 applications.
`(#:configure-flags
(list (string-append "-DCMAKE_INSTALL_QT5PLUGINDIR="
%output "/lib/qt5/plugins")
- "-DENABLE_QT4=Off")))
+ (string-append "-DCMAKE_INSTALL_QT6PLUGINDIR="
+ %output "/lib/qt6/plugins")
+ "-DENABLE_QT4=Off"
+ "-DENABLE_QT6=ON")))
(inputs
`(("fcitx5" ,fcitx5)
("libxcb" ,libxcb)
("libxkbcommon" ,libxkbcommon)
- ("qtbase" ,qtbase-5)
+ ("qtbase-5" ,qtbase-5)
+ ("qtbase" ,qtbase)
+ ("qtwayland" ,qtwayland)
+ ("wayland" ,wayland)
("gettext" ,gettext-minimal)))
(native-inputs
(list extra-cmake-modules))